summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-23 13:28:53 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-23 13:35:39 +0200
commitcf6799d066d0e72287b962f3ceec521788d0a358 (patch)
tree960ea652ad411d6614fa0235a41120daeec145b8 /dev-python/restructuredtext-lint
parentdev-python/python-gammu: Enable py3.9 (diff)
downloadgentoo-cf6799d066d0e72287b962f3ceec521788d0a358.tar.gz
gentoo-cf6799d066d0e72287b962f3ceec521788d0a358.tar.bz2
gentoo-cf6799d066d0e72287b962f3ceec521788d0a358.zip
dev-python/restructuredtext-lint: Enable py3.9 & py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/restructuredtext-lint')
-rw-r--r--dev-python/restructuredtext-lint/restructuredtext-lint-1.3.0.ebuild19
1 files changed, 6 insertions, 13 deletions
diff --git a/dev-python/restructuredtext-lint/restructuredtext-lint-1.3.0.ebuild b/dev-python/restructuredtext-lint/restructuredtext-lint-1.3.0.ebuild
index 2773dd5e0a1c..d71a4addd03d 100644
--- a/dev-python/restructuredtext-lint/restructuredtext-lint-1.3.0.ebuild
+++ b/dev-python/restructuredtext-lint/restructuredtext-lint-1.3.0.ebuild
@@ -2,27 +2,22 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
+MY_P="${P/-/_}"
DESCRIPTION="Checks PyPI validity of reStructuredText"
HOMEPAGE="https://pypi.org/project/restructuredtext_lint/"
-
-MY_P="restructuredtext_lint"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_P}/${MY_P}-${PV}.tar.gz"
-S="${WORKDIR}/${MY_P}-${PV}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/_}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
LICENSE="Unlicense"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-DEPEND="
+BDEPEND="
test? (
- dev-python/nose[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
)
"
@@ -30,6 +25,4 @@ RDEPEND="
>=dev-python/docutils-0.11[${PYTHON_USEDEP}]
<dev-python/docutils-1.0[${PYTHON_USEDEP}]"
-python_test() {
- nosetests -v || die
-}
+distutils_enable_tests nose