summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-23 14:41:43 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-23 14:41:43 -0800
commitb57c8664fd5a16940ffc1e869c58127f7e33086a (patch)
treec112c86d42fc4808f8cbd70e2df6f61da3e9f649 /dev-python/rfc3986-validator/rfc3986-validator-0.1.1.ebuild
parentdev-python/rfc3987-1.3.8-r1: actually add py38 (diff)
downloadgentoo-b57c8664fd5a16940ffc1e869c58127f7e33086a.tar.gz
gentoo-b57c8664fd5a16940ffc1e869c58127f7e33086a.tar.bz2
gentoo-b57c8664fd5a16940ffc1e869c58127f7e33086a.zip
dev-python/rfc3986-validator: New package
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/rfc3986-validator/rfc3986-validator-0.1.1.ebuild')
-rw-r--r--dev-python/rfc3986-validator/rfc3986-validator-0.1.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/rfc3986-validator/rfc3986-validator-0.1.1.ebuild b/dev-python/rfc3986-validator/rfc3986-validator-0.1.1.ebuild
new file mode 100644
index 000000000000..7931e4b13427
--- /dev/null
+++ b/dev-python/rfc3986-validator/rfc3986-validator-0.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+
+inherit distutils-r1
+
+# 0.1.1 isn't tagged on GitHub
+COMMIT_HASH="ee3dcca0df300e0584e129a4ab81828be002684b"
+MY_PN="${PN//-/_}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Pure python RFC3986 validator"
+HOMEPAGE="https://pypi.org/project/rfc3986-validator/ https://github.com/naimetti/rfc3986-validator"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/rfc3987[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # remove dep on pytest-runner
+ sed -i -r "s:('|\")pytest-runner('|\")(,|)::" setup.py || die
+ distutils-r1_python_prepare_all
+}