summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-28 08:49:55 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-28 09:00:07 +0200
commit4e843e0ca3835dab025e26adb8d93be1a93e5224 (patch)
tree1ba3c7360fd455831ecf4ec8dbfd4f6c72d8f000 /dev-python/rfc3986
parentdev-python/rfc3339-validator: Add missing test-dep on hypothesis (diff)
downloadgentoo-4e843e0ca3835dab025e26adb8d93be1a93e5224.tar.gz
gentoo-4e843e0ca3835dab025e26adb8d93be1a93e5224.tar.bz2
gentoo-4e843e0ca3835dab025e26adb8d93be1a93e5224.zip
dev-python/rfc3986: Modernize, py3.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rfc3986')
-rw-r--r--dev-python/rfc3986/rfc3986-1.3.2.ebuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/dev-python/rfc3986/rfc3986-1.3.2.ebuild b/dev-python/rfc3986/rfc3986-1.3.2.ebuild
index 5d5064b5811d..d30c59714ba3 100644
--- a/dev-python/rfc3986/rfc3986-1.3.2.ebuild
+++ b/dev-python/rfc3986/rfc3986-1.3.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3)
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3)
inherit distutils-r1
@@ -15,16 +15,13 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="idna test"
-RESTRICT="!test? ( test )"
+IUSE="idna"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
+RDEPEND="
idna? ( dev-python/idna[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"
-RDEPEND=""
+BDEPEND="
+ test? ( dev-python/idna[${PYTHON_USEDEP}] )
+"
-python_test() {
- py.test -vv || die
-}
+distutils_enable_tests pytest