summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-25 20:42:51 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-25 20:51:55 +0200
commitab69ef7237c2a1ca87dd521a4c4bd53e20116d31 (patch)
tree7affbb6e81ba6a321d0f2f8c809471e43ca6fbfb /dev-python/rfc3986
parentdev-python/rfc3986: Add python@ as co-maint (diff)
downloadgentoo-ab69ef7237c2a1ca87dd521a4c4bd53e20116d31.tar.gz
gentoo-ab69ef7237c2a1ca87dd521a4c4bd53e20116d31.tar.bz2
gentoo-ab69ef7237c2a1ca87dd521a4c4bd53e20116d31.zip
dev-python/rfc3986: Bump to 1.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rfc3986')
-rw-r--r--dev-python/rfc3986/Manifest1
-rw-r--r--dev-python/rfc3986/rfc3986-1.4.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/rfc3986/Manifest b/dev-python/rfc3986/Manifest
index a7c98c77d759..b5023286e087 100644
--- a/dev-python/rfc3986/Manifest
+++ b/dev-python/rfc3986/Manifest
@@ -1,2 +1,3 @@
DIST rfc3986-1.2.0.tar.gz 40162 BLAKE2B d51db37285366fdc7a6d25632afe440bbcdf4fbca46488082286824f046cfd81129b8f0e0695f986120276cf446dde5751dc52ebeb5f2f61f60c5acb92f2da1a SHA512 b88bdc47fa2daa6a9ffc339b1b997a85d0c8b3bf3ab271554e2a1a684c0394370e9cba07a82a542f39533a4c8cae69414234545db6caa2508e0ee7e7f8bdff3d
DIST rfc3986-1.3.2.tar.gz 44225 BLAKE2B f4cc72ed3c2dcc7132527cd33fd6b9f0136f789fdb229cc33b02bf2dd596b2f762e3e4cf8af63f239408b55cdf056cf54315a0a9cdf734a4203fad24b00ce594 SHA512 c086c55295d80ccf33dbfeff06059303119e7a407bfc405b7f75ec30413221ec58d3061d75fd3ca696b7acf9b1be1dfcc785e01280bf659a53be43ab1f300b15
+DIST rfc3986-1.4.0.tar.gz 44912 BLAKE2B 595a644f8f92823ad31113ce88218cb30d16b37ec7303c0d8e89d2d2b1e18448d99003e95d61dcf09cb64aae517037bae798d1e89c74b652d517a648e80856e8 SHA512 dbcddc09331b794eafed8c2d7b81b7b632ba5cae2741e33ad12e781bc923427a05febd2f2715d037f35769b18c8d790546dfd4bbebe6e71d35777745e446888b
diff --git a/dev-python/rfc3986/rfc3986-1.4.0.ebuild b/dev-python/rfc3986/rfc3986-1.4.0.ebuild
new file mode 100644
index 000000000000..a132830441ff
--- /dev/null
+++ b/dev-python/rfc3986/rfc3986-1.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{6..9} pypy3)
+
+inherit distutils-r1
+
+DESCRIPTION="Validating URI References per RFC 3986"
+HOMEPAGE="https://tools.ietf.org/html/rfc3986
+ https://github.com/python-hyper/rfc3986
+ https://rfc3986.rtfd.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="idna"
+
+RDEPEND="
+ idna? ( dev-python/idna[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? ( dev-python/idna[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest