summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-04 15:59:16 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-04 16:22:49 +0200
commit0ad67cd3112e91636bc91b4aeea3033b92437872 (patch)
tree81b4fc73a30241c4d2c30d8dc002c8d7dcad752a /dev-python/rich/rich-10.1.0.ebuild
parentdev-python/docutils: Bump to 0.17 (diff)
downloadgentoo-0ad67cd3112e91636bc91b4aeea3033b92437872.tar.gz
gentoo-0ad67cd3112e91636bc91b4aeea3033b92437872.tar.bz2
gentoo-0ad67cd3112e91636bc91b4aeea3033b92437872.zip
dev-python/rich: Bump to 10.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rich/rich-10.1.0.ebuild')
-rw-r--r--dev-python/rich/rich-10.1.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/rich/rich-10.1.0.ebuild b/dev-python/rich/rich-10.1.0.ebuild
new file mode 100644
index 000000000000..a62e88778e09
--- /dev/null
+++ b/dev-python/rich/rich-10.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for renrering rich text, tables, etc. to the terminal"
+HOMEPAGE="https://github.com/willmcgugan/rich"
+SRC_URI="https://github.com/willmcgugan/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}