summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-04-05 20:55:36 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-04-05 20:55:36 +0300
commitccbe3ba9c06336e98dca0e8d5fd7e162e30a9ace (patch)
tree8780e7560f9de84dd5beafae53c17b1ec589980a /dev-python/rich/rich-12.2.0.ebuild
parentdev-python/google-api-python-client: add 2.43.0 (diff)
downloadgentoo-ccbe3ba9c06336e98dca0e8d5fd7e162e30a9ace.tar.gz
gentoo-ccbe3ba9c06336e98dca0e8d5fd7e162e30a9ace.tar.bz2
gentoo-ccbe3ba9c06336e98dca0e8d5fd7e162e30a9ace.zip
dev-python/rich: add 12.2.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/rich/rich-12.2.0.ebuild')
-rw-r--r--dev-python/rich/rich-12.2.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/rich/rich-12.2.0.ebuild b/dev-python/rich/rich-12.2.0.ebuild
new file mode 100644
index 000000000000..4cbcc9174b3c
--- /dev/null
+++ b/dev-python/rich/rich-12.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for renrering rich text, tables, etc. to the terminal"
+HOMEPAGE="https://github.com/Textualize/rich"
+SRC_URI="
+ https://github.com/Textualize/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x COLUMNS=80
+ epytest -p no:pytest-qt
+}
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}