summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-06 17:19:35 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-06 17:38:36 +0100
commit392d01603649bcba80d2b0c25fe17e1978021032 (patch)
treee598603a4dc7a5e9de5b354b45e11dc2b019b921 /dev-python/rich/rich-9.13.0.ebuild
parentsys-kernel/git-sources: Linux version 5.12-rc2 (diff)
downloadgentoo-392d01603649bcba80d2b0c25fe17e1978021032.tar.gz
gentoo-392d01603649bcba80d2b0c25fe17e1978021032.tar.bz2
gentoo-392d01603649bcba80d2b0c25fe17e1978021032.zip
dev-python/rich: Bump to 9.13.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rich/rich-9.13.0.ebuild')
-rw-r--r--dev-python/rich/rich-9.13.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/rich/rich-9.13.0.ebuild b/dev-python/rich/rich-9.13.0.ebuild
new file mode 100644
index 000000000000..a62e88778e09
--- /dev/null
+++ b/dev-python/rich/rich-9.13.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for renrering rich text, tables, etc. to the terminal"
+HOMEPAGE="https://github.com/willmcgugan/rich"
+SRC_URI="https://github.com/willmcgugan/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}