summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-15 09:15:48 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-15 09:27:16 +0100
commitfd1bc6b0ad0d82387303577013175ee0aff8eecb (patch)
treebb0430aab840cb0f1e156c9eafc19b06dfb61bd7 /dev-python/rjsmin
parentsys-libs/musl: use ${ED} not ${D} in sysroot hack (diff)
downloadgentoo-fd1bc6b0ad0d82387303577013175ee0aff8eecb.tar.gz
gentoo-fd1bc6b0ad0d82387303577013175ee0aff8eecb.tar.bz2
gentoo-fd1bc6b0ad0d82387303577013175ee0aff8eecb.zip
dev-python/rjsmin: Bump to 1.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rjsmin')
-rw-r--r--dev-python/rjsmin/Manifest1
-rw-r--r--dev-python/rjsmin/rjsmin-1.2.0.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/rjsmin/Manifest b/dev-python/rjsmin/Manifest
index 93f4f5a06c5d..6e72f9cc9972 100644
--- a/dev-python/rjsmin/Manifest
+++ b/dev-python/rjsmin/Manifest
@@ -1 +1,2 @@
DIST rjsmin-1.1.0.gh.tar.gz 437054 BLAKE2B 83b24f1ee94ded66a70ed75b3e494b3e6948edf82fecc80f261964fd2bb032a8cb496ed919f461131b3381c402a6397e65bfa5031f46691c4badfc5e9e2faea2 SHA512 5e168e51e1716fe35a3520fba828d721638094a6f6f73deb4c49183d8cd51531131962e2c7092ada092da63c4ddd615215088bd1a9e474d508f80dc0603d3118
+DIST rjsmin-1.2.0.gh.tar.gz 443279 BLAKE2B 7cb000485fd134fdc590b90766357b0eea5b33a9baf2fb12623ad5a882ac545aa7dd3f447a23c95da3cdf79f44e4f369d48b1cb2e08b790ef7376e9b6c9fa4d8 SHA512 bc40dd59d7dd4e106170db473ef3c3c6df74abdc93d098521f91212a08476541f13a97663c9f56498188c59b3876242c6c81a5633fea84d83e8ab2f7a4d918ad
diff --git a/dev-python/rjsmin/rjsmin-1.2.0.ebuild b/dev-python/rjsmin/rjsmin-1.2.0.ebuild
new file mode 100644
index 000000000000..ef45a0bd23f0
--- /dev/null
+++ b/dev-python/rjsmin/rjsmin-1.2.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Javascript minifier written in python."
+HOMEPAGE="http://opensource.perlig.de/rjsmin/"
+SRC_URI="
+ https://github.com/ndparker/rjsmin/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest