summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-08-04 16:59:21 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-08-05 15:52:44 +0200
commit4eaaed8d918e55afd25f3ff19c58c7912dfb04c7 (patch)
tree5a301069b238859e3d4bb0fc50e84b859c618b62 /dev-python/roman
parentdev-python/fs: version bump. (diff)
downloadgentoo-4eaaed8d918e55afd25f3ff19c58c7912dfb04c7.tar.gz
gentoo-4eaaed8d918e55afd25f3ff19c58c7912dfb04c7.tar.bz2
gentoo-4eaaed8d918e55afd25f3ff19c58c7912dfb04c7.zip
dev-python/roman: version bump.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/roman')
-rw-r--r--dev-python/roman/Manifest1
-rw-r--r--dev-python/roman/roman-3.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/roman/Manifest b/dev-python/roman/Manifest
index 3a8b639e6ed7..d27b3ecb660f 100644
--- a/dev-python/roman/Manifest
+++ b/dev-python/roman/Manifest
@@ -1 +1,2 @@
DIST roman-2.0.0.zip 7590 BLAKE2B c733a4e905ebf4ef526afb5088744bde8558314b059a4d8e9f86e914af2657f99b5c4364e9e8f9a11d9a1e4470ba9b1919b19951aab7dc06b55539d27b89ab30 SHA512 d62a95e835232821dbf7a81d0c6b7df63f18c4116cfc7eee0c691a0b31d3d7b69d2dc2e4ea26e0a169a8e24bf080e8bb1e195b853be4adf1491335a5b4d5702c
+DIST roman-3.0.tar.gz 5184 BLAKE2B 0951e15a1fbf0feecc98c4318fa631a535d24d9559d21e800f065923c71d094c387b18c5926ad55322ad8417a2db97626ada1e110549938d73243ca410e3ab87 SHA512 468a4ac7188cdf3155698f260de5ecc5bb2072c120c79d046618ac07b6de6f777cfc69661f2e0df4ca66359bb20169d22599b3f342edaa48f8575bdc17b40c08
diff --git a/dev-python/roman/roman-3.0.ebuild b/dev-python/roman/roman-3.0.ebuild
new file mode 100644
index 000000000000..deedd46e8b51
--- /dev/null
+++ b/dev-python/roman/roman-3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="An Integer to Roman numerals converter"
+HOMEPAGE="https://pypi.org/project/roman/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ !<dev-python/docutils-0.9[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ cp "${S}/src/tests.py" . || die "copying test file failed"
+ esetup.py test
+}