summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-02-17 07:22:29 -0800
committerMatt Turner <mattst88@gentoo.org>2020-02-17 07:55:43 -0800
commit59aaf1df5546e712d455f0113692e6447b5c6f56 (patch)
tree6718d4cfcc9ba4495efa54e7b5a49985d884dd8a /dev-python/rope/rope-0.16.0.ebuild
parentmedia-gfx/word_cloud: Initial import. (diff)
downloadgentoo-59aaf1df5546e712d455f0113692e6447b5c6f56.tar.gz
gentoo-59aaf1df5546e712d455f0113692e6447b5c6f56.tar.bz2
gentoo-59aaf1df5546e712d455f0113692e6447b5c6f56.zip
dev-python/rope: Fix test execution with python3.7
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-python/rope/rope-0.16.0.ebuild')
-rw-r--r--dev-python/rope/rope-0.16.0.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-python/rope/rope-0.16.0.ebuild b/dev-python/rope/rope-0.16.0.ebuild
index a60999bb3c8d..7854b2c3f39a 100644
--- a/dev-python/rope/rope-0.16.0.ebuild
+++ b/dev-python/rope/rope-0.16.0.ebuild
@@ -21,9 +21,11 @@ IUSE="doc"
# setup.py, using standard docutils builds docs successfully.
DEPEND="doc? ( dev-python/docutils[${PYTHON_USEDEP}] )"
-python_test() {
- PYTHONPATH="${BUILD_DIR}/lib:." ${EPYTHON} ropetest/__init__.py
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-python3.7.patch
+)
+
+distutils_enable_tests pytest
python_compile_all() {
if use doc; then
@@ -33,7 +35,7 @@ python_compile_all() {
for i in ./*.rst; do
rst2html.py $i > ./build/${i/rst/html} || die
done
- popd > /dev/null || die
+ popd > /dev/null || die
fi
}