summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-30 15:32:43 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-30 15:32:43 +0300
commit6b440763995cafc3236d10fdd715a0e8fdc8ab2b (patch)
treeecb916279d2940fe28bc26b9bc9e11dbf9b4782c /dev-python/rope
parentdev-python/dj-database-url: add 1.0.0 (diff)
downloadgentoo-6b440763995cafc3236d10fdd715a0e8fdc8ab2b.tar.gz
gentoo-6b440763995cafc3236d10fdd715a0e8fdc8ab2b.tar.bz2
gentoo-6b440763995cafc3236d10fdd715a0e8fdc8ab2b.zip
dev-python/rope: add 1.3.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/rope')
-rw-r--r--dev-python/rope/Manifest1
-rw-r--r--dev-python/rope/rope-1.3.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/rope/Manifest b/dev-python/rope/Manifest
index 0b54e70e1e81..536f617df1ab 100644
--- a/dev-python/rope/Manifest
+++ b/dev-python/rope/Manifest
@@ -1,2 +1,3 @@
DIST rope-1.1.1.tar.gz 274610 BLAKE2B 52354453305ee58db70f86392f7ec27179e1e4a9ec677fb8875bb9ca24663e6dae26e1bac4a1ad62143fe3a419a7a1e1fd0b7d2f03ef556143d2b060b23300af SHA512 aaf664a63ef00e3c844d6999338fe6a3384ddecfe95ef9b7eb213e5c37c9f78f7d2ea59aa7e612487bac5eaaaf7fc8ba499c0d43c740f99a7b3be64c9d7f6e07
DIST rope-1.2.0.tar.gz 289239 BLAKE2B 314cf382e76a448dcddff0b9c52ae437cde032b54f1c9edbb05c1d47832ecc7a0b35b8eb14cf48ef5b296011a273cf3e21c5433a70e2627c11f2cdeca885e1a3 SHA512 d34a47a6453a85fcaa253287224b7b5265e08d2cba46377d17502f78642d3468d074b43d4916758c2225f98e676080af2b7896ad6194e0ee0234661343259fd1
+DIST rope-1.3.0.tar.gz 286846 BLAKE2B f8b122a276812638eee76cc235e91e013696f6047c450729edde1b4a5bfdd1d6aa7d1e9ac46048e8205a1f544ee82f740e0f7b20f10769a9a28065a8b9caee6b SHA512 45036cfb3abbe6b00306268f62804d787a633ef8981b23553d57ea18087bfbec33be6346bb59393bb6c3b48020a2da87f759668a57ec8e809ba3666aff0dfd2c
diff --git a/dev-python/rope/rope-1.3.0.ebuild b/dev-python/rope/rope-1.3.0.ebuild
new file mode 100644
index 000000000000..67e1183ee5b0
--- /dev/null
+++ b/dev-python/rope/rope-1.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="
+ https://pypi.org/project/rope/
+ https://github.com/python-rope/rope/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="doc"
+
+RDEPEND="
+ dev-python/pytoolconfig[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # our venv style confuses this comparison
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_source_typing
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_typing
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_compiled
+)