summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-23 09:23:32 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-23 10:15:50 +0100
commit8048f896547b86cc76dfc0dd2e757eabe41b7ebd (patch)
treef89463adefa58d98e6f527bce4a653c32ff9abe3 /dev-python/rosdistro/rosdistro-0.6.1.ebuild
parentdev-ros/cmake_modules: Bump to 0.4.1 (diff)
downloadgentoo-8048f896547b86cc76dfc0dd2e757eabe41b7ebd.tar.gz
gentoo-8048f896547b86cc76dfc0dd2e757eabe41b7ebd.tar.bz2
gentoo-8048f896547b86cc76dfc0dd2e757eabe41b7ebd.zip
dev-python/rosdistro: Bump to 0.6.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/rosdistro/rosdistro-0.6.1.ebuild')
-rw-r--r--dev-python/rosdistro/rosdistro-0.6.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/rosdistro/rosdistro-0.6.1.ebuild b/dev-python/rosdistro/rosdistro-0.6.1.ebuild
new file mode 100644
index 000000000000..6f235cc43c15
--- /dev/null
+++ b/dev-python/rosdistro/rosdistro-0.6.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rosdistro"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Tools to work with catkinized rosdistro files"
+HOMEPAGE="http://wiki.ros.org/rosdistro"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ https://github.com/ros-infrastructure/rosdistro/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests --with-xunit test || die
+}