summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-03-19 09:11:30 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-03-19 16:02:40 +0200
commit06c26bdca603204ebfa4f0451048e16103327342 (patch)
treeaf50e74bee14e9bfdb3c778715ccc57b7b229873 /dev-python/rospkg
parentsys-kernel/gentoo-sources: add 5.16.16 (diff)
downloadgentoo-06c26bdca603204ebfa4f0451048e16103327342.tar.gz
gentoo-06c26bdca603204ebfa4f0451048e16103327342.tar.bz2
gentoo-06c26bdca603204ebfa4f0451048e16103327342.zip
dev-python/rospkg: add 1.4.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/rospkg')
-rw-r--r--dev-python/rospkg/Manifest1
-rw-r--r--dev-python/rospkg/rospkg-1.4.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/rospkg/Manifest b/dev-python/rospkg/Manifest
index 86a5e1d1ebaa..b7f842ecfb06 100644
--- a/dev-python/rospkg/Manifest
+++ b/dev-python/rospkg/Manifest
@@ -1 +1,2 @@
DIST rospkg-1.3.0.tar.gz 91442 BLAKE2B 9bf217ff103513471b1a2b0812e4b08519d667c0b883c545b23dd42f10216390f4fb618bf67baed0ba2aba71c18c13b0a702445425ca29568394c0cc5b4dff61 SHA512 bfd67eee80e063db45eb98b1b73cf1865d23a14a55d72639890d7ad3d01f4c85f07aa662d9d66e996340798c002f5ee9d1167cee32b20caff900fe527ed50d5b
+DIST rospkg-1.4.0.tar.gz 91707 BLAKE2B 02ee199a5f59d1256561cda0e9a6f05e40337a604bfba34d076cd09812fb4cd2f253785e894e9590de86226e8e250d77f50f18c4ffb2857c69095f329c7aa58e SHA512 4e4a40961ed1cfba0746069725378414dc61d3f55e479e7af5efa211419e34e44f5964f8ab41a8c4c9e9b74ae275fd29cf6ffda0eab66b6a0ec7fc7066719797
diff --git a/dev-python/rospkg/rospkg-1.4.0.ebuild b/dev-python/rospkg/rospkg-1.4.0.ebuild
new file mode 100644
index 000000000000..430b4a135478
--- /dev/null
+++ b/dev-python/rospkg/rospkg-1.4.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Standalone Python library for the ROS package system"
+HOMEPAGE="https://wiki.ros.org/rospkg"
+
+if [[ ${PV} = *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rospkg"
+ inherit git-r3
+
+ S="${WORKDIR}/${PN}"
+ EGIT_CHECKOUT_DIR="${S}"
+else
+ SRC_URI="https://github.com/ros-infrastructure/rospkg/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+PATCHES=(
+ "${FILESDIR}/gentoo.patch"
+)
+
+distutils_enable_tests pytest