summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-16 14:29:15 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-23 17:06:28 +0300
commit67ef28832c62b655353a438c7a886270f8993b1f (patch)
tree836ed0ef516076d00d9a418b199a10d2d2366c8d /dev-python/rospkg
parentdev-python/ament_package: enable py3.10, use d_e_t (diff)
downloadgentoo-67ef28832c62b655353a438c7a886270f8993b1f.tar.gz
gentoo-67ef28832c62b655353a438c7a886270f8993b1f.tar.bz2
gentoo-67ef28832c62b655353a438c7a886270f8993b1f.zip
dev-python/rospkg: enable py3.10, use d_e_t
passes tests Closes: https://bugs.gentoo.org/806860 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/rospkg')
-rw-r--r--dev-python/rospkg/rospkg-1.3.0.ebuild16
-rw-r--r--dev-python/rospkg/rospkg-9999.ebuild16
2 files changed, 6 insertions, 26 deletions
diff --git a/dev-python/rospkg/rospkg-1.3.0.ebuild b/dev-python/rospkg/rospkg-1.3.0.ebuild
index 9a43e2fb6d1e..fbd4db374f38 100644
--- a/dev-python/rospkg/rospkg-1.3.0.ebuild
+++ b/dev-python/rospkg/rospkg-1.3.0.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8,3_9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+
+PYTHON_COMPAT=( python3_{8..10} )
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -27,26 +27,16 @@ fi
LICENSE="BSD"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/catkin_pkg[${PYTHON_USEDEP}]
dev-python/distro[${PYTHON_USEDEP}]
"
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-DEPEND="${RDEPEND} ${BDEPEND}
test? (
- dev-python/coverage[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
)
"
PATCHES=( "${FILESDIR}/gentoo.patch" "${FILESDIR}/yaml_load.patch" )
-python_test() {
- nosetests --with-coverage --cover-package=rospkg --with-xunit test || die
-}
+distutils_enable_tests nose
diff --git a/dev-python/rospkg/rospkg-9999.ebuild b/dev-python/rospkg/rospkg-9999.ebuild
index 9a43e2fb6d1e..fbd4db374f38 100644
--- a/dev-python/rospkg/rospkg-9999.ebuild
+++ b/dev-python/rospkg/rospkg-9999.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8,3_9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+
+PYTHON_COMPAT=( python3_{8..10} )
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -27,26 +27,16 @@ fi
LICENSE="BSD"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/catkin_pkg[${PYTHON_USEDEP}]
dev-python/distro[${PYTHON_USEDEP}]
"
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-DEPEND="${RDEPEND} ${BDEPEND}
test? (
- dev-python/coverage[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
)
"
PATCHES=( "${FILESDIR}/gentoo.patch" "${FILESDIR}/yaml_load.patch" )
-python_test() {
- nosetests --with-coverage --cover-package=rospkg --with-xunit test || die
-}
+distutils_enable_tests nose