summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-04 14:16:41 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-04 14:17:08 +0200
commita6240b3c84b188f2783f97f04d075d30fe09cf73 (patch)
tree068ad2bb1d6a67e61608c9e2d05010e2fe817fde /dev-python/routes
parentdev-python/smmap: Remove old (diff)
downloadgentoo-a6240b3c84b188f2783f97f04d075d30fe09cf73.tar.gz
gentoo-a6240b3c84b188f2783f97f04d075d30fe09cf73.tar.bz2
gentoo-a6240b3c84b188f2783f97f04d075d30fe09cf73.zip
dev-python/routes: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/routes')
-rw-r--r--dev-python/routes/routes-2.4.1.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/dev-python/routes/routes-2.4.1.ebuild b/dev-python/routes/routes-2.4.1.ebuild
deleted file mode 100644
index fed9cbe23a3f..000000000000
--- a/dev-python/routes/routes-2.4.1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
-
-inherit distutils-r1
-
-MY_PN="Routes"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A re-implementation of Rails routes system, mapping URLs to Controllers/Actions"
-HOMEPAGE="https://routes.readthedocs.io/en/latest/ https://pypi.org/project/Routes/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-RDEPEND=">=dev-python/repoze-lru-0.3[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-
-# The testsuite appears to be held back by the author
-
-S="${WORKDIR}/${MY_P}"
-
-# https://github.com/bbangert/routes/issues/42 presents a patch
-# for the faulty docbuild converted to sed stmnts
-python_prepare_all() {
- # The default theme in sphinx switched to classic from shpinx-1.3.1
- if has_version ">=dev-python/sphinx-1.3.1"; then
- sed -e "s:html_theme_options = {:html_theme = 'classic'\n&:" \
- -i docs/conf.py || die
- else
- sed -e "s:html_theme_options = {:html_theme = 'default'\n&:" \
- -i docs/conf.py || die
- fi
- sed -e "s:changes:changes\n todo:" \
- -i docs/index.rst || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}