summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-08-20 10:27:04 +0800
committerIan Delaney <idella4@gentoo.org>2015-08-20 10:28:14 +0800
commitd31c1bc9a6c1f46765e36ee5737bb41b414fda8a (patch)
tree9e38f35694eb57603b6b26008c1c850d67ca4c19 /dev-python/routes
parentsys-kernel/genkernel: lazy update to eapi 5 (diff)
downloadgentoo-d31c1bc9a6c1f46765e36ee5737bb41b414fda8a.tar.gz
gentoo-d31c1bc9a6c1f46765e36ee5737bb41b414fda8a.tar.bz2
gentoo-d31c1bc9a6c1f46765e36ee5737bb41b414fda8a.zip
dev-python/routes: bump
This release has improved python3 support, remove test phase and deps since author consistently holds back the testsuite, remove old Package-Manager: portage-2.2.20
Diffstat (limited to 'dev-python/routes')
-rw-r--r--dev-python/routes/Manifest3
-rw-r--r--dev-python/routes/routes-1.13-r1.ebuild42
-rw-r--r--dev-python/routes/routes-2.0.ebuild61
-rw-r--r--dev-python/routes/routes-2.1-r1.ebuild2
-rw-r--r--dev-python/routes/routes-2.1.ebuild53
-rw-r--r--dev-python/routes/routes-2.2.ebuild56
6 files changed, 58 insertions, 159 deletions
diff --git a/dev-python/routes/Manifest b/dev-python/routes/Manifest
index 756d2866ee7a..968f045910bc 100644
--- a/dev-python/routes/Manifest
+++ b/dev-python/routes/Manifest
@@ -1,3 +1,2 @@
-DIST Routes-1.13.tar.gz 797539 SHA256 cc03d1a357cdb7af82e3909ee8ff93cb2b2afb48aca23bfde0117d6f49f624a7 SHA512 052b04e0ee803394ffe1675a075fb633e790fdcabf1ee012a73d0c4ef211b4d0b18be13f680537fe5f8424193245d0b4bb2d76a20b9e74707e73b25e076a9f6a WHIRLPOOL 7b83a24719ca2e051f9ba44ca712c10c2eca1590e1fc39afb731777de9c9bd73af4ef99868bf1e3dfa688ff38b9068f30311fe146973d9b55e1c61c501a08ebb
-DIST Routes-2.0.tar.gz 199195 SHA256 6e4eb6437a9def22e1344ee8f766d7795bedfe6f615d3ea138e4035d6fbd33f8 SHA512 a049efc8774ded555f597d165cc536891cf7c008a753cb0d3c44ebb5c763e117b5050c0ef68489e05f7d9bd6009250465cc56ce6954010a84ec9b3416f728e91 WHIRLPOOL b9e5e88071c32c51427cfb16ad16cdea4cdace35579b053ea4fd2e81b27858c163244fd7976e2bdf93ab79e413ba72e48b2db8fc6991a6199ef7ba56c9620e5a
DIST Routes-2.1.tar.gz 179737 SHA256 ebf4126e244cf11414653b5ba5f27ed4abfad38b906a01e5d4c93d3ce5568ea3 SHA512 6dcea3e20d9883e29d6aea5949eef3b265094f46084234a15530c266930163918c6eb2ad00bb49cd9cbf947a0019c2d91a5455f997bc7a7e5b8c662837a728c2 WHIRLPOOL fbdb8e1a84aa2b1b8bf011aa68a31364f0fd48cabcaaf413274679f34e514283fbd8aac9497444b24f69f7d72393f38aeab5eeeb96659e3aae009ed2eebc4fbf
+DIST Routes-2.2.tar.gz 180011 SHA256 9fa78373d63e36c3d8af6e33cfcad743f70c012c7ad6f2c3bf89ad973b9ab514 SHA512 ddd88c412fce902aa75be46dd564bea7fed630116d50c0f08db6813de26bbb7af5adf7366dd3664a0fc10e369ed5089f6cc9ac91cc236e1b45c828fe2deee2e2 WHIRLPOOL 9fe75ce3826e64ff46db35fdb47c655f86709fdbfb64ad317b2f672e761a717bc2b4c2fd18f1675b36922d65300cd2f7acec87cb08ceeb50cb85fb099c15209f
diff --git a/dev-python/routes/routes-1.13-r1.ebuild b/dev-python/routes/routes-1.13-r1.ebuild
deleted file mode 100644
index 36483a4792cf..000000000000
--- a/dev-python/routes/routes-1.13-r1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit distutils-r1
-
-MY_PN="Routes"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A Python re-implementation of the Rails routes system for mapping URL's to Controllers/Actions"
-HOMEPAGE="http://routes.groovie.org http://pypi.python.org/pypi/Routes"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-# Note: although setup.py states that tests require webtest,
-# it isn't used anywhere.
-RDEPEND="dev-python/webob[${PYTHON_USEDEP}]
- dev-python/repoze-lru[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_test() {
- nosetests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/routes/routes-2.0.ebuild b/dev-python/routes/routes-2.0.ebuild
deleted file mode 100644
index 5ca16711f526..000000000000
--- a/dev-python/routes/routes-2.0.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-inherit distutils-r1
-
-MY_PN="Routes"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A Python re-implementation of the Rails routes system for mapping URL's to Controllers/Actions"
-HOMEPAGE="http://routes.groovie.org http://pypi.python.org/pypi/Routes"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-RDEPEND="dev-python/webob[${PYTHON_USEDEP}]
- >=dev-python/repoze-lru-0.3[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/webtest[${PYTHON_USEDEP}]
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.0-tests-py3.patch
- "${FILESDIR}"/${PN}-2.0-setup.py.patch
-)
-
-python_prepare_all() {
- use test && DISTUTILS_IN_SOURCE_BUILD=1
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- cp -r tests "${BUILD_DIR}" || die
- if [[ ${EPYTHON} == python3* ]]; then
- 2to3 -w --no-diffs "${BUILD_DIR}"/tests || die
- fi
-
- nosetests -w "${BUILD_DIR}"/tests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/routes/routes-2.1-r1.ebuild b/dev-python/routes/routes-2.1-r1.ebuild
index 55d3d993f8ed..4d45d09b2476 100644
--- a/dev-python/routes/routes-2.1-r1.ebuild
+++ b/dev-python/routes/routes-2.1-r1.ebuild
@@ -36,7 +36,7 @@ S="${WORKDIR}/${MY_P}"
# Comment out patch for tests for now
#PATCHES=( "${FILESDIR}"/${PN}-2.0-tests-py3.patch )
-# https://github.com/bbangert/routes/issues/42 presents a patch
+# https://github.com/bbangert/routes/issues/42 presents a patch
# for the faulty docbuild converted to sed stmnts
python_prepare_all() {
use test && DISTUTILS_IN_SOURCE_BUILD=1
diff --git a/dev-python/routes/routes-2.1.ebuild b/dev-python/routes/routes-2.1.ebuild
deleted file mode 100644
index 9859278ed071..000000000000
--- a/dev-python/routes/routes-2.1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-inherit distutils-r1
-
-MY_PN="Routes"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A Python re-implementation of Rails routes system, mapping URL's to Controllers/Actions"
-HOMEPAGE="http://routes.groovie.org http://pypi.python.org/pypi/Routes"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="test"
-
-RDEPEND=">=dev-python/repoze-lru-0.3[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/webtest[${PYTHON_USEDEP}]
- )"
-# It appears there's an epidemic of missing testsuites coming out of github. Restrict for now
-RESTRICT="test"
-
-S="${WORKDIR}/${MY_P}"
-
-# Comment out patch for tests for now
-#PATCHES=( "${FILESDIR}"/${PN}-2.0-tests-py3.patch )
-
-# The doc build possibly never built. Just know that the doc builds in
-# neither the previous nor this
-# https://github.com/bbangert/routes/issues/42
-python_prepare_all() {
- use test && DISTUTILS_IN_SOURCE_BUILD=1
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- cp -r tests "${BUILD_DIR}" || die
- if [[ ${EPYTHON} == python3* ]]; then
- 2to3 -w --no-diffs "${BUILD_DIR}"/tests || die
- fi
-
- nosetests -w "${BUILD_DIR}"/tests || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/routes/routes-2.2.ebuild b/dev-python/routes/routes-2.2.ebuild
new file mode 100644
index 000000000000..8e58027d4d40
--- /dev/null
+++ b/dev-python/routes/routes-2.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="Routes"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A Python re-implementation of Rails routes system, mapping URL's to Controllers/Actions"
+HOMEPAGE="http://routes.groovie.org http://pypi.python.org/pypi/Routes"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+RDEPEND=">=dev-python/repoze-lru-0.3[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+# The testsuite appears to be held back by the author
+
+S="${WORKDIR}/${MY_P}"
+
+# https://github.com/bbangert/routes/issues/42 presents a patch
+# for the faulty docbuild converted to sed stmnts
+python_prepare_all() {
+ # The default theme in sphinx switched to classic from shpinx-1.3.1
+ if has_version ">=dev-python/sphinx-1.3.1"; then
+ sed -e "s:html_theme_options = {:html_theme = 'classic'\n&:" \
+ -i docs/conf.py || die
+ else
+ sed -e "s:html_theme_options = {:html_theme = 'default'\n&:" \
+ -i docs/conf.py || die
+ fi
+ sed -e "s:changes:changes\n todo:" \
+ -i docs/index.rst || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}