summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-24 11:14:55 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-24 13:10:17 +0100
commit9f54681354c90133b653edcac76215e7669fd7a9 (patch)
tree4b04102fd0aa7a36325df46593b76489715338cd /dev-python/rpy
parentdev-python/rsa: Version Bump (diff)
downloadgentoo-9f54681354c90133b653edcac76215e7669fd7a9.tar.gz
gentoo-9f54681354c90133b653edcac76215e7669fd7a9.tar.bz2
gentoo-9f54681354c90133b653edcac76215e7669fd7a9.zip
dev-python/rpy: Version Bump
Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/rpy')
-rw-r--r--dev-python/rpy/Manifest1
-rw-r--r--dev-python/rpy/rpy-2.7.4.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/rpy/Manifest b/dev-python/rpy/Manifest
index 9235ac0acc95..73ababb0f0dc 100644
--- a/dev-python/rpy/Manifest
+++ b/dev-python/rpy/Manifest
@@ -1,3 +1,4 @@
DIST rpy2-2.6.2.tar.gz 171655 SHA256 2e28886b2a6a138cfc057f9b7cddade253e61c9abb43f0eae20dace58b6dfced SHA512 7a060ccc26a03dc93d75edb85d92f1ab31af96ba140932ff8e699cd5855e6078b1e0ffceed135d32deb6c8f273ebcc8b02be38e9b8fc66778cc2adab5745f542 WHIRLPOOL 26d9a9c13e4efa22a232507cfff0b13d650e0528f635dfa9fe464cde50462d2d94a668d1566b537bafaa5462eb66e96005296c6295308b1e3d1c5639da2879b6
DIST rpy2-2.7.2.tar.gz 176481 SHA256 b8c376c2bb78a602effa44c654633f7a11b9bcc582aa3d4828a11302bc290e21 SHA512 d282e81cdd4c69ac4655d019151e2c7ce0aaeeb55479f7f7405ed16ac4124d2f3eedccb37a7d563deb0d8beb69e5ede4d6702a3872b554965442a38ec545f1f4 WHIRLPOOL f19182a1ef392d1b4029ebd984d8828d92ea3bf14c9375490fa099d7a2f82e99c75eb6475dba1d11270bf76dc94eee490157e22ab2c083c51a90b3c1d1a56b7a
DIST rpy2-2.7.3.tar.gz 176854 SHA256 fc66a4efa113b48ac32cd4578d5fce551722cd64c5eadafdcab36f074e9e785c SHA512 dd0e5eb896bf809d4d342f7927c5bc014b78352df87219d9d0839622647c35f256a256593d526be2faf369ccd98d74868e1b6b3c99ebc830d08fa4cfb8c35121 WHIRLPOOL 735eb08c1528c27f2362d42e08cf9ff5c31cbcdf706eefb873921ed9eaeab4d9004b80335d36672b3711dd8a8515d51d451a1f66bebe4a4d4c9ef1f32e758685
+DIST rpy2-2.7.4.tar.gz 177030 SHA256 478f40c6775cc04188818d0410cd8340d900bd782ab3fa734cb6c090ecd57ddf SHA512 8e228418e9721021de588fc91afb87b0fe07d6f84c325a093415442c57d694f557f1672a270f1984a693f753be9e2a49c80717b1f5cdcdc616509d4c88962651 WHIRLPOOL d350d27ece993c0f6a348238c8888653ced225184be1e98ddc1eef6a8774e1564da2f51b7bd3342b88241c4f7fe4484cb9488c729222eae10208c06ed93d30b5
diff --git a/dev-python/rpy/rpy-2.7.4.ebuild b/dev-python/rpy/rpy-2.7.4.ebuild
new file mode 100644
index 000000000000..6262c69dd2fc
--- /dev/null
+++ b/dev-python/rpy/rpy-2.7.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 flag-o-matic
+
+MYSLOT=2
+MY_PN=${PN}${MYSLOT}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python interface to the R Programming Language"
+HOMEPAGE="http://rpy.sourceforge.net/ https://pypi.python.org/pypi/rpy2"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="AGPL-3 GPL-2 LGPL-2.1 MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-lang/R-3.1
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.13.1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+PDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
+
+# ggplot2 is an optional test dep but not in portage
+S="${WORKDIR}/${MY_P}"
+
+# Tarball absent of doc files in doc folder
+# https://bitbucket.org/rpy2/rpy2/issues/229
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ ${PYTHON} -m 'rpy2.tests' || die
+}