summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-30 10:33:18 +0100
committerSam James <sam@gentoo.org>2021-06-30 10:33:18 +0100
commitec92277b3a0bf883e12149503a08aed25a852597 (patch)
tree0ca4acd9ea73bdc70fcfe341ded5b7b5fb29b0af /dev-python/rq/rq-1.9.0.ebuild
parentdev-ruby/yard: Stabilize 0.9.26 ppc64, #799305 (diff)
downloadgentoo-ec92277b3a0bf883e12149503a08aed25a852597.tar.gz
gentoo-ec92277b3a0bf883e12149503a08aed25a852597.tar.bz2
gentoo-ec92277b3a0bf883e12149503a08aed25a852597.zip
dev-python/rq: add 1.9.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/rq/rq-1.9.0.ebuild')
-rw-r--r--dev-python/rq/rq-1.9.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/rq/rq-1.9.0.ebuild b/dev-python/rq/rq-1.9.0.ebuild
new file mode 100644
index 000000000000..61e8398709eb
--- /dev/null
+++ b/dev-python/rq/rq-1.9.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="simple, lightweight library for creating and processing background jobs"
+HOMEPAGE="https://python-rq.org https://github.com/rq/rq"
+SRC_URI="https://github.com/rq/rq/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/click-5.0[${PYTHON_USEDEP}]
+ >=dev-python/redis-py-3.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/sentry-sdk[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+ local redis_test_config="daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ "
+
+ # Spawn Redis itself for testing purposes
+ # NOTE: On sam@'s machine, spawning Redis can hang in the sandbox.
+ # I'm not restricting tests yet because this doesn't happen for anyone else AFAICT.
+ elog "Spawning Redis"
+ elog "NOTE: Port ${redis_port} must be free"
+ /usr/sbin/redis-server - <<< "${redis_test_config}" || die
+
+ # Run the actual tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}