summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-10 22:39:05 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-10 22:39:05 +0200
commit19dfd10dbb36fdf8d766ba2c5750bd754e752983 (patch)
tree4fc029d30e01faafb84b8d71a45353a6683285ab /dev-python/rq
parentdev-python/argon2-cffi-bindings: Stabilize 21.2.0 arm64, #830962 (diff)
downloadgentoo-19dfd10dbb36fdf8d766ba2c5750bd754e752983.tar.gz
gentoo-19dfd10dbb36fdf8d766ba2c5750bd754e752983.tar.bz2
gentoo-19dfd10dbb36fdf8d766ba2c5750bd754e752983.zip
dev-python/rq: enable py3.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/rq')
-rw-r--r--dev-python/rq/rq-1.10.1-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/rq/rq-1.10.1-r1.ebuild b/dev-python/rq/rq-1.10.1-r1.ebuild
new file mode 100644
index 000000000000..ec467b29af9a
--- /dev/null
+++ b/dev-python/rq/rq-1.10.1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="simple, lightweight library for creating and processing background jobs"
+HOMEPAGE="https://python-rq.org https://github.com/rq/rq"
+SRC_URI="https://github.com/rq/rq/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/click-5.0[${PYTHON_USEDEP}]
+ >=dev-python/redis-py-3.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/sentry-sdk[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+ local redis_test_config="daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ "
+
+ # Spawn Redis itself for testing purposes
+ # NOTE: On sam@'s machine, spawning Redis can hang in the sandbox.
+ # I'm not restricting tests yet because this doesn't happen for anyone else AFAICT.
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ /usr/sbin/redis-server - <<< "${redis_test_config}" || die
+
+ # Run the actual tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}