summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-14 10:43:06 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-14 10:53:37 +0100
commit395446ea359ac59712c86ec10b950301bdf596aa (patch)
tree78dccd87f1606f10a957184ad3c6b40b6a885b19 /dev-python/rsa/rsa-3.3.ebuild
parentdev-python/sphinx: Version Bump (diff)
downloadgentoo-395446ea359ac59712c86ec10b950301bdf596aa.tar.gz
gentoo-395446ea359ac59712c86ec10b950301bdf596aa.tar.bz2
gentoo-395446ea359ac59712c86ec10b950301bdf596aa.zip
dev-python/rsa: Version Bump
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/rsa/rsa-3.3.ebuild')
-rw-r--r--dev-python/rsa/rsa-3.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/rsa/rsa-3.3.ebuild b/dev-python/rsa/rsa-3.3.ebuild
new file mode 100644
index 000000000000..65aede9ec6f9
--- /dev/null
+++ b/dev-python/rsa/rsa-3.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python RSA implementation"
+HOMEPAGE="http://stuvel.eu/rsa https://pypi.python.org/pypi/rsa"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pyasn1-0.1.3[${PYTHON_USEDEP}]
+ dev-python/traceback2[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-0.6.10[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ nosetests --verbose || die
+}