summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2020-06-17 23:20:45 -0400
committerAaron Bauman <bman@gentoo.org>2020-06-17 23:20:45 -0400
commit7beacde9746149b88470517083dbc917524fdd75 (patch)
treef14f9955d8d0b7681dd8c4ba37e54e87d7d00257 /dev-python/rsa/rsa-3.4.2-r1.ebuild
parentdev-python/httplib2: drop vulnerable (diff)
downloadgentoo-7beacde9746149b88470517083dbc917524fdd75.tar.gz
gentoo-7beacde9746149b88470517083dbc917524fdd75.tar.bz2
gentoo-7beacde9746149b88470517083dbc917524fdd75.zip
dev-python/rsa: drop vulnerable
Bug: https://bugs.gentoo.org/727888 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-python/rsa/rsa-3.4.2-r1.ebuild')
-rw-r--r--dev-python/rsa/rsa-3.4.2-r1.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-python/rsa/rsa-3.4.2-r1.ebuild b/dev-python/rsa/rsa-3.4.2-r1.ebuild
deleted file mode 100644
index bc2b7755ef5e..000000000000
--- a/dev-python/rsa/rsa-3.4.2-r1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Pure-Python RSA implementation"
-HOMEPAGE="https://stuvel.eu/rsa https://pypi.org/project/rsa/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/pyasn1-0.1.3[${PYTHON_USEDEP}]
- dev-python/traceback2[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- )
- "
-
-python_test() {
- nosetests --verbose || die
-}