summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-11-06 09:16:45 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-11-06 09:17:01 +0100
commit0885ccf77508351e0ce2a29f1b0e4661eceebb1f (patch)
treead4e5d67f549fa52fc2bb409db41c7221effdc53 /dev-python/rsa/rsa-3.4.2.ebuild
parentdev-python/hypothesis: Bump (diff)
downloadgentoo-0885ccf77508351e0ce2a29f1b0e4661eceebb1f.tar.gz
gentoo-0885ccf77508351e0ce2a29f1b0e4661eceebb1f.tar.bz2
gentoo-0885ccf77508351e0ce2a29f1b0e4661eceebb1f.zip
dev-python/rsa: Bump
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-python/rsa/rsa-3.4.2.ebuild')
-rw-r--r--dev-python/rsa/rsa-3.4.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/rsa/rsa-3.4.2.ebuild b/dev-python/rsa/rsa-3.4.2.ebuild
new file mode 100644
index 000000000000..56fce15122fc
--- /dev/null
+++ b/dev-python/rsa/rsa-3.4.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python RSA implementation"
+HOMEPAGE="http://stuvel.eu/rsa https://pypi.python.org/pypi/rsa"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pyasn1-0.1.3[${PYTHON_USEDEP}]
+ dev-python/traceback2[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-0.6.10[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ nosetests --verbose || die
+}