summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-01-23 00:16:10 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-01-23 00:40:23 +0100
commit74e0f1489beaceed8f5bac87b75fb1ab9174a90a (patch)
tree67bc0ce0b30040b466f61df1e050e8695ab05188 /dev-python/rsa
parentdev-python/botocore: drop Python 3.5 support (diff)
downloadgentoo-74e0f1489beaceed8f5bac87b75fb1ab9174a90a.tar.gz
gentoo-74e0f1489beaceed8f5bac87b75fb1ab9174a90a.tar.bz2
gentoo-74e0f1489beaceed8f5bac87b75fb1ab9174a90a.zip
dev-python/rsa: add Python 3.8 support
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-python/rsa')
-rw-r--r--dev-python/rsa/rsa-3.4.2-r1.ebuild (renamed from dev-python/rsa/rsa-3.4.2.ebuild)6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/rsa/rsa-3.4.2.ebuild b/dev-python/rsa/rsa-3.4.2-r1.ebuild
index 43599947175f..54427c1aaa8d 100644
--- a/dev-python/rsa/rsa-3.4.2.ebuild
+++ b/dev-python/rsa/rsa-3.4.2-r1.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -22,7 +23,6 @@ RDEPEND="
dev-python/traceback2[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
- >=dev-python/setuptools-0.6.10[${PYTHON_USEDEP}]
test? (
dev-python/nose[${PYTHON_USEDEP}]
dev-python/unittest2[${PYTHON_USEDEP}]