summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/rst2pdf/rst2pdf-0.93-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/rst2pdf/rst2pdf-0.93-r2.ebuild')
-rw-r--r--dev-python/rst2pdf/rst2pdf-0.93-r2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/rst2pdf/rst2pdf-0.93-r2.ebuild b/dev-python/rst2pdf/rst2pdf-0.93-r2.ebuild
new file mode 100644
index 000000000000..5cedc238598a
--- /dev/null
+++ b/dev-python/rst2pdf/rst2pdf-0.93-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Tool for transforming reStructuredText to PDF using ReportLab"
+HOMEPAGE="http://rst2pdf.ralsina.com.ar/ http://pypi.python.org/pypi/rst2pdf"
+SRC_URI="http://rst2pdf.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~hppa ~ppc ~ppc64 x86"
+IUSE="svg"
+
+DEPEND="dev-python/docutils[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ dev-python/pdfrw[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/reportlab-2.6[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ svg? ( media-gfx/svg2rlg )"
+RDEPEND="${DEPEND}"
+# >=reportlab-2.6: https://code.google.com/p/rst2pdf/issues/detail?id=474
+
+python_prepare_all() {
+ epatch "${FILESDIR}/${P}-fix-logging.patch"
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ dodoc doc/*.pdf
+ doman doc/rst2pdf.1
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "rst2pdf can work with the following packages for additional functionality:"
+ elog " dev-python/sphinx - versatile documentation creation"
+ elog " dev-python/pythonmagick - image processing with ImageMagick"
+ elog " dev-python/matplotlib - mathematical formulae"
+ elog "It can also use wordaxe for hyphenation, but this package is not"
+ elog "available in the portage tree yet. Please refer to the manual"
+ elog "installed in /usr/share/doc/${PF}/ for more information."
+ fi
+}