summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-04-24 15:52:37 +0100
committerMarek Szuba <marecki@gentoo.org>2020-04-24 15:53:39 +0100
commita71b7e7c5bd7f88047e02477d7d2bb367b801c94 (patch)
tree1228028889f46e6ccd952ceda342484b3c83fda3 /dev-python/ruamel-yaml-clib/ruamel-yaml-clib-0.2.0.ebuild
parentdev-python/twisted: Skip tests failing on py2.7 (diff)
downloadgentoo-a71b7e7c5bd7f88047e02477d7d2bb367b801c94.tar.gz
gentoo-a71b7e7c5bd7f88047e02477d7d2bb367b801c94.tar.bz2
gentoo-a71b7e7c5bd7f88047e02477d7d2bb367b801c94.zip
dev-python/ruamel-yaml-clib: new package, sort of
This used to be part of dev-python/ruamel-yaml prior to its version 0.16 (which is why why have already got ~arm64 and ~x86 in KEYWORDS), now however it is a (theoretically optional) separate package. Assigning myself as maintainer for the time being, that said I'll be happy to transfer it to Andrey and Foster once they have reported back on the subject of ruamel.yaml version bump. Bug: https://bugs.gentoo.org/711070 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/ruamel-yaml-clib/ruamel-yaml-clib-0.2.0.ebuild')
-rw-r--r--dev-python/ruamel-yaml-clib/ruamel-yaml-clib-0.2.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/ruamel-yaml-clib/ruamel-yaml-clib-0.2.0.ebuild b/dev-python/ruamel-yaml-clib/ruamel-yaml-clib-0.2.0.ebuild
new file mode 100644
index 000000000000..ef3e670faf7e
--- /dev/null
+++ b/dev-python/ruamel-yaml-clib/ruamel-yaml-clib-0.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+MY_PN="${PN//-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="C-based reader/scanner and emitter for dev-python/ruamel-yaml"
+HOMEPAGE="https://pypi.org/project/ruamel.yaml.clib/ https://sourceforge.net/p/ruamel-yaml-clib"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="!<dev-python/ruamel-yaml-0.16.0"
+
+S="${WORKDIR}"/${MY_P}
+
+python_install() {
+ distutils-r1_python_install --single-version-externally-managed
+}