summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-12-26 20:50:15 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-12-26 20:50:15 +0200
commit284d94d6cbbb56b5b3a8630406bfc3fad9ee3e80 (patch)
tree39ba1f77fd35e2c47ffbca89769d875090bcf181 /dev-python/ruamel-yaml
parentsys-process/fcron: Stabilize 3.2.1-r8 arm, #827888 (diff)
downloadgentoo-284d94d6cbbb56b5b3a8630406bfc3fad9ee3e80.tar.gz
gentoo-284d94d6cbbb56b5b3a8630406bfc3fad9ee3e80.tar.bz2
gentoo-284d94d6cbbb56b5b3a8630406bfc3fad9ee3e80.zip
dev-python/ruamel-yaml: add 0.17.19
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/ruamel-yaml')
-rw-r--r--dev-python/ruamel-yaml/Manifest1
-rw-r--r--dev-python/ruamel-yaml/ruamel-yaml-0.17.19.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/ruamel-yaml/Manifest b/dev-python/ruamel-yaml/Manifest
index 8eece641589b..2709407427b7 100644
--- a/dev-python/ruamel-yaml/Manifest
+++ b/dev-python/ruamel-yaml/Manifest
@@ -1,2 +1,3 @@
DIST ruamel.yaml-0.17.17.tar.xz 184120 BLAKE2B 05bd1dd719677918a49798f377c5e52bd1b8c7e3bd38a416626330baec90f3e7a71509f236151be73b1773e48ae02d25ac01ef970ebe6cf15ccca49a01a996d1 SHA512 72fbdda33c193dfb556367d79b50e148d2aecd4f2b04cf5b48f2dcf4b690e0796b40273995badec655891408bb8ba6a7e84992e6911e55e75ab453403da3397f
DIST ruamel.yaml-0.17.18.tar.xz 184412 BLAKE2B 47fc39b8811b19507a99a88408660ed9eef0182a91cdc86976d04f055361b9cf296e4761433207d47c8343c184c2f6358cb4541af4efce19be6865f492d11939 SHA512 dc11868522904463aba8d7d85e4c44d0d72c6fa84381089647546bde5ab091f733476d04f088611222ad4cac818dbbc7b24c51f721f34d94bdeae82fe0c627ae
+DIST ruamel.yaml-0.17.19.tar.xz 184508 BLAKE2B dea922cab102f8a73888df2af8093a0c6ae51bae93ceb34f5cf58d1c9be407b65b52b000688213aed41ba14cf39506193a13102d8cd0a6597c8f7d30cc15a0fb SHA512 5f1daeead463e8fc0de43f2180ef1b536036d01c3aa1fdeaf6854789c0170dd54a09d72055b5528ed836f8323b3bec79b85c409812d7ab3c09de0e98f03f4c33
diff --git a/dev-python/ruamel-yaml/ruamel-yaml-0.17.19.ebuild b/dev-python/ruamel-yaml/ruamel-yaml-0.17.19.ebuild
new file mode 100644
index 000000000000..f87789872e5e
--- /dev/null
+++ b/dev-python/ruamel-yaml/ruamel-yaml-0.17.19.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+MY_P="${P/-/.}"
+DESCRIPTION="YAML parser/emitter that supports roundtrip comment preservation"
+HOMEPAGE="
+ https://pypi.org/project/ruamel.yaml/
+ https://sourceforge.net/p/ruamel-yaml/"
+# PyPI tarballs do not include tests
+SRC_URI="mirror://sourceforge/ruamel-dl-tagged-releases/${MY_P}.tar.xz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/namespace-ruamel[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml-clib[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/ruamel-std-pathlib[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+# Old PyYAML tests from lib/ require special set-up and are invoked indirectly
+# via test_z_olddata, tell pytest itself to leave the subdir alone.
+python_test() {
+ local deselect=()
+
+ [[ ${EPYTHON} == pypy3 ]] && deselect+=(
+ _test/test_deprecation.py::test_collections_deprecation
+ )
+
+ epytest --ignore _test/lib/ ${deselect[@]/#/--deselect }
+}
+
+python_install() {
+ distutils-r1_python_install --single-version-externally-managed
+ find "${ED}" -name '*.pth' -delete || die
+}