summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-09 22:35:56 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-10 00:07:30 -0500
commitaac5703d819689e5e5806efaee8c26cb3a91616e (patch)
treee4e15ee4dd9d8859d24dfa27acf9396e8500feb2 /dev-python/s3fs
parentdev-python/moto: add py37 support to 1.0.1-r1 (diff)
downloadgentoo-aac5703d819689e5e5806efaee8c26cb3a91616e.tar.gz
gentoo-aac5703d819689e5e5806efaee8c26cb3a91616e.tar.bz2
gentoo-aac5703d819689e5e5806efaee8c26cb3a91616e.zip
dev-python/s3fs: add py37 support to 0.1.5
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/s3fs')
-rw-r--r--dev-python/s3fs/s3fs-0.1.5.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/dev-python/s3fs/s3fs-0.1.5.ebuild b/dev-python/s3fs/s3fs-0.1.5.ebuild
index 7d5331d9706e..59484f376301 100644
--- a/dev-python/s3fs/s3fs-0.1.5.ebuild
+++ b/dev-python/s3fs/s3fs-0.1.5.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
inherit distutils-r1
@@ -23,8 +22,8 @@ DEPEND="
${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
- dev-python/moto[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
)"
python_test() {