summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-10 16:00:45 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-10 16:02:06 +0200
commitb929540acb2a7c73096a03f264f4f5b1e732f8e2 (patch)
tree3aa0eb9c33610955d6b4370b874f8d7e61e45a68 /dev-python/s3transfer/s3transfer-0.3.3.ebuild
parentdev-python/s3transfer: Port to py3.9 (diff)
downloadgentoo-b929540acb2a7c73096a03f264f4f5b1e732f8e2.tar.gz
gentoo-b929540acb2a7c73096a03f264f4f5b1e732f8e2.tar.bz2
gentoo-b929540acb2a7c73096a03f264f4f5b1e732f8e2.zip
dev-python/s3transfer: Bump to 0.3.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/s3transfer/s3transfer-0.3.3.ebuild')
-rw-r--r--dev-python/s3transfer/s3transfer-0.3.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/s3transfer/s3transfer-0.3.3.ebuild b/dev-python/s3transfer/s3transfer-0.3.3.ebuild
new file mode 100644
index 000000000000..843a42f09de1
--- /dev/null
+++ b/dev-python/s3transfer/s3transfer-0.3.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+DESCRIPTION="An Amazon S3 Transfer Manager"
+HOMEPAGE="https://github.com/boto/s3transfer"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/botocore[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests nose
+
+PATCHES=(
+ "${FILESDIR}"/${P}-py38.patch
+)
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "tests failed under ${EPYTHON}"
+}