summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-27 07:04:47 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-27 07:56:24 +0200
commit0699ebcf51fd1d59b92e716265149794634798ee (patch)
tree7f03d65e187430b57373a894cbc41c1329bdbf2c /dev-python/s3transfer/s3transfer-0.7.0.ebuild
parentdev-python/botocore: Bump to 1.31.55 (diff)
downloadgentoo-0699ebcf51fd1d59b92e716265149794634798ee.tar.gz
gentoo-0699ebcf51fd1d59b92e716265149794634798ee.tar.bz2
gentoo-0699ebcf51fd1d59b92e716265149794634798ee.zip
dev-python/s3transfer: Bump to 0.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/s3transfer/s3transfer-0.7.0.ebuild')
-rw-r--r--dev-python/s3transfer/s3transfer-0.7.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/s3transfer/s3transfer-0.7.0.ebuild b/dev-python/s3transfer/s3transfer-0.7.0.ebuild
new file mode 100644
index 000000000000..76b0dda7ac2a
--- /dev/null
+++ b/dev-python/s3transfer/s3transfer-0.7.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="An Amazon S3 Transfer Manager"
+HOMEPAGE="
+ https://github.com/boto/s3transfer/
+ https://pypi.org/project/s3transfer/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-1.24.7[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest tests/{unit,functional}
+}