summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-14 08:44:08 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-14 09:28:28 +0100
commitb80251eaad7153b694c384a74ada9becb60f4c5c (patch)
tree5688991316d32f8314e53543318685afd4aecc74 /dev-python/s3transfer/s3transfer-0.9.0.ebuild
parentdev-python/botocore: Bump to 1.34.0 (diff)
downloadgentoo-b80251eaad7153b694c384a74ada9becb60f4c5c.tar.gz
gentoo-b80251eaad7153b694c384a74ada9becb60f4c5c.tar.bz2
gentoo-b80251eaad7153b694c384a74ada9becb60f4c5c.zip
dev-python/s3transfer: Bump to 0.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/s3transfer/s3transfer-0.9.0.ebuild')
-rw-r--r--dev-python/s3transfer/s3transfer-0.9.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/s3transfer/s3transfer-0.9.0.ebuild b/dev-python/s3transfer/s3transfer-0.9.0.ebuild
new file mode 100644
index 000000000000..103c98396afb
--- /dev/null
+++ b/dev-python/s3transfer/s3transfer-0.9.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="An Amazon S3 Transfer Manager"
+HOMEPAGE="
+ https://github.com/boto/s3transfer/
+ https://pypi.org/project/s3transfer/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-1.33.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest tests/{unit,functional}
+}