summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-08-06 13:46:19 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-08-06 15:49:46 +0200
commit2c157efb222d14e2700b6e7f95921c98415f961c (patch)
treea2adcac09cb5110806c0b159c7a7e36ce2feb200 /dev-python/sabyenc/sabyenc-4.0.2.ebuild
parentmedia-sound/musescore: bump to 3.5 + updated 9999 (diff)
downloadgentoo-2c157efb222d14e2700b6e7f95921c98415f961c.tar.gz
gentoo-2c157efb222d14e2700b6e7f95921c98415f961c.tar.bz2
gentoo-2c157efb222d14e2700b6e7f95921c98415f961c.zip
dev-python/sabyenc: bump to v4.0.2
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-python/sabyenc/sabyenc-4.0.2.ebuild')
-rw-r--r--dev-python/sabyenc/sabyenc-4.0.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/sabyenc/sabyenc-4.0.2.ebuild b/dev-python/sabyenc/sabyenc-4.0.2.ebuild
new file mode 100644
index 000000000000..6c6fdf9e58be
--- /dev/null
+++ b/dev-python/sabyenc/sabyenc-4.0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module providing raw yEnc encoding/decoding for SABnzbd"
+HOMEPAGE="https://github.com/sabnzbd/sabyenc"
+SRC_URI="https://github.com/sabnzbd/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DOCS=( CHANGES.md README.md doc/yenc-draft.1.3.txt )
+
+DEPEND="test? (
+ dev-python/chardet[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest