summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Klausmann <klausman@gentoo.org>2016-08-31 19:04:11 +0200
committerTobias Klausmann <klausman@gentoo.org>2016-08-31 19:04:11 +0200
commit326109b068b0fb2875ecec1bd6e553d557247036 (patch)
tree3599452c786c132be9e5a5287de5500191ed6ada /dev-python/scapy-python3/scapy-python3-0.18-r1.ebuild
parentsys-apps/openrc: Stable for HPPA (bug #588786). (diff)
downloadgentoo-326109b068b0fb2875ecec1bd6e553d557247036.tar.gz
gentoo-326109b068b0fb2875ecec1bd6e553d557247036.tar.bz2
gentoo-326109b068b0fb2875ecec1bd6e553d557247036.zip
dev-python/scapy-python3: block against net-analyzer/scapy
Put in a block while I figure out how to fix the file collision. Gentoo-Bug: 592612
Diffstat (limited to 'dev-python/scapy-python3/scapy-python3-0.18-r1.ebuild')
-rw-r--r--dev-python/scapy-python3/scapy-python3-0.18-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/scapy-python3/scapy-python3-0.18-r1.ebuild b/dev-python/scapy-python3/scapy-python3-0.18-r1.ebuild
new file mode 100644
index 000000000000..501586c100bc
--- /dev/null
+++ b/dev-python/scapy-python3/scapy-python3-0.18-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_{3,4,5} )
+
+IUSE="test"
+inherit distutils-r1
+
+DESCRIPTION="Packet crafting/sending/... PCAP processing tool with python3 compatibility"
+HOMEPAGE="https://pypi.python.org/pypi/scapy-python3/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ !net-analyzer/scapy
+ "