summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-05-19 00:00:08 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-05-19 23:54:33 +0200
commit9a7c17cc622213f79235fb14869e3a61b5bfef1c (patch)
tree47e7d6341843f5f3c4361e9ae6eb23142035ff31 /dev-python/schema/schema-0.6.6.ebuild
parentwww-apps/piwigo: 2.9.0 bump (diff)
downloadgentoo-9a7c17cc622213f79235fb14869e3a61b5bfef1c.tar.gz
gentoo-9a7c17cc622213f79235fb14869e3a61b5bfef1c.tar.bz2
gentoo-9a7c17cc622213f79235fb14869e3a61b5bfef1c.zip
dev-python/schema: version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/schema/schema-0.6.6.ebuild')
-rw-r--r--dev-python/schema/schema-0.6.6.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/schema/schema-0.6.6.ebuild b/dev-python/schema/schema-0.6.6.ebuild
new file mode 100644
index 000000000000..a85bb01f7f3e
--- /dev/null
+++ b/dev-python/schema/schema-0.6.6.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for validating Python data structures"
+HOMEPAGE="https://pypi.python.org/pypi/schema https://github.com/keleshev/schema"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://github.com/keleshev/schema/archive/v${PV}.zip -> ${P}.tar.gz
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"