summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-12-08 14:01:43 -0500
committerAaron Bauman <bman@gentoo.org>2019-12-08 14:19:14 -0500
commitc83b48420b7ee012f156338a86b6f976519019c9 (patch)
tree782064d79e8b3e09ee5e53e75e4086a43bdfbff6 /dev-python/scientificpython
parentdev-python/numpy: drop last-rited ebuild (diff)
downloadgentoo-c83b48420b7ee012f156338a86b6f976519019c9.tar.gz
gentoo-c83b48420b7ee012f156338a86b6f976519019c9.tar.bz2
gentoo-c83b48420b7ee012f156338a86b6f976519019c9.zip
profiles/package.mask: drop last-rited pkgs
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-python/scientificpython')
-rw-r--r--dev-python/scientificpython/Manifest1
-rw-r--r--dev-python/scientificpython/files/scientificpython-2.9-mpi.patch40
-rw-r--r--dev-python/scientificpython/files/scientificpython-2.9.3-mpi-netcdf.patch43
-rw-r--r--dev-python/scientificpython/metadata.xml22
-rw-r--r--dev-python/scientificpython/scientificpython-2.9.4.ebuild69
5 files changed, 0 insertions, 175 deletions
diff --git a/dev-python/scientificpython/Manifest b/dev-python/scientificpython/Manifest
deleted file mode 100644
index 8ed2616faa61..000000000000
--- a/dev-python/scientificpython/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST ScientificPython-2.9.4.tar.gz 688704 BLAKE2B 8f125f11aa466ca2dd3afe5642385ac06350ea299e377aa4c368b3090ad0606e9d20e86a0b0f0a8b80408d11f558eb08abc630b185973318fa9df7f02b9b959f SHA512 8bd3ce3ead090832582711c25f7d4c7a5a55642ef9a1e845fb68b4b3dba833ba86baf9c444fd9948ce761a5357dbf388a2c1a860a66ee13fdf1f26d1010cc8c8
diff --git a/dev-python/scientificpython/files/scientificpython-2.9-mpi.patch b/dev-python/scientificpython/files/scientificpython-2.9-mpi.patch
deleted file mode 100644
index 3140779c74a9..000000000000
--- a/dev-python/scientificpython/files/scientificpython-2.9-mpi.patch
+++ /dev/null
@@ -1,40 +0,0 @@
---- Src/MPI/compile.py
-+++ Src/MPI/compile.py
-@@ -4,7 +4,7 @@
- # Normally nothing needs to be changed below
- import distutils
- import distutils.sysconfig
--import os, sys
-+import os, subprocess, sys
- from Scientific import N
-
- cfgDict = distutils.sysconfig.get_config_vars()
-@@ -32,16 +32,16 @@
- items[i] = os.path.join(frameworkdir[0], items[i])
- linkforshared = ' '.join(items)
-
--cmd = '%s %s -o mpipython -I%s %s %s -L%s -lpython%s %s %s' % \
-- (mpicompiler,
-- linkforshared,
-- cfgDict['INCLUDEPY'],
-- extra_compile_args,
-- sources,
-- cfgDict['LIBPL'],
-- cfgDict['VERSION'],
-- cfgDict['LIBS'],
-- cfgDict['LIBM'])
-+cmd = [mpicompiler]
-+cmd.extend(linkforshared.split())
-+cmd.extend(os.environ.get("CFLAGS", "").split())
-+cmd.extend(os.environ.get("LDFLAGS", "").split())
-+cmd.extend(["-o", "mpipython"])
-+cmd.extend(["-I" + x for x in cfgDict['INCLUDEPY'].split()])
-+cmd.extend(["-I../../Include"])
-+cmd.extend(extra_compile_args.split())
-+cmd.extend(sources.split())
-+cmd.extend(["-lpython%s" % cfgDict['VERSION']])
-
--print 'cmd = ', cmd
--os.system(cmd)
-+print 'cmd =', " ".join(cmd)
-+sys.exit(subprocess.call(cmd))
diff --git a/dev-python/scientificpython/files/scientificpython-2.9.3-mpi-netcdf.patch b/dev-python/scientificpython/files/scientificpython-2.9.3-mpi-netcdf.patch
deleted file mode 100644
index c9672948f2f8..000000000000
--- a/dev-python/scientificpython/files/scientificpython-2.9.3-mpi-netcdf.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 71a5e881290c1cec2506a346e2740a1b821c36aa Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Thu, 13 Mar 2014 15:29:33 +0100
-Subject: [PATCH] Include MPI cflags/ldflags for netcdf.
-
----
- setup.py | 7 +++++--
- 1 file changed, 5 insertions(+), 2 deletions(-)
-
-diff --git a/setup.py b/setup.py
-index 7f01656..71ac92a 100644
---- a/setup.py
-+++ b/setup.py
-@@ -2,7 +2,7 @@
-
- from distutils.core import setup, Extension
- from distutils.command.install_headers import install_headers
--import os, sys, platform
-+import os, sys, platform, subprocess
- from glob import glob
-
- class Dummy:
-@@ -92,13 +92,16 @@ else:
- netcdf_include = os.path.join(netcdf_prefix, 'include')
- netcdf_h_file = os.path.join(netcdf_prefix, 'include', 'netcdf.h')
- netcdf_lib = os.path.join(netcdf_prefix, 'lib')
-+ mpi_cflags = subprocess.Popen(["mpicc", "-showme:compile"], stdout=subprocess.PIPE).communicate()[0].rstrip().split()
-+ mpi_ldflags = subprocess.Popen(["mpicc", "-showme:link"], stdout=subprocess.PIPE).communicate()[0].rstrip().split()
- ext_modules = [Extension('Scientific._netcdf',
- ['Scientific/_netcdf.c'],
- include_dirs=['Include', netcdf_include]
- + numpy_include,
- library_dirs=[netcdf_lib],
- libraries = ['netcdf'],
-- extra_compile_args=extra_compile_args)]
-+ extra_compile_args=extra_compile_args + mpi_cflags,
-+ extra_link_args=mpi_ldflags)]
-
- try:
- # Add code for including documentation in Mac packages
---
-1.9.0
-
diff --git a/dev-python/scientificpython/metadata.xml b/dev-python/scientificpython/metadata.xml
deleted file mode 100644
index ead81e593755..000000000000
--- a/dev-python/scientificpython/metadata.xml
+++ /dev/null
@@ -1,22 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <longdescription lang="en">
- ScientificPython is a collection of Python modules that are useful for
- scientific computing. In this collection you will find modules that
- cover basic geometry (vectors, tensors, transformations, vector and
- tensor fields), quaternions, automatic derivatives, linear
- interpolation, polynomials, elementary statistics, nonlinear
- least-squares fits, unit calculations, Fortran-compatible text
- formatting, 3D visualization via VRML, and two Tk widgets for simple
- line plots and 3D wireframe models.
-</longdescription>
-</pkgmetadata>
diff --git a/dev-python/scientificpython/scientificpython-2.9.4.ebuild b/dev-python/scientificpython/scientificpython-2.9.4.ebuild
deleted file mode 100644
index a760b97ee758..000000000000
--- a/dev-python/scientificpython/scientificpython-2.9.4.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-MY_PN="ScientificPython"
-MY_P="${MY_PN}-${PV}"
-DOWNLOAD_NUMBER=4570
-
-DESCRIPTION="Scientific Module for Python"
-SRC_URI="http://sourcesup.cru.fr/frs/download.php/${DOWNLOAD_NUMBER}/${MY_P}.tar.gz"
-HOMEPAGE="http://sourcesup.cru.fr/projects/scientific-py/"
-
-LICENSE="CeCILL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc mpi test"
-
-RDEPEND="
- <dev-python/numpy-1.9[${PYTHON_USEDEP}]
- dev-python/pyro:3[${PYTHON_USEDEP}]
- sci-libs/netcdf
- mpi? ( virtual/mpi )"
-DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=( "${FILESDIR}"/${PN}-2.9-mpi.patch )
-DOCS=( README README.MPI Doc/CHANGELOG Examples/demomodule.c Examples/netcdf_demo.py )
-
-python_prepare_all() {
- use mpi && PATCHES+=( "${FILESDIR}"/${PN}-2.9.3-mpi-netcdf.patch )
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- distutils-r1_python_compile
-
- if use mpi; then
- cd Src/MPI || die
- ${PYTHON} compile.py || die
- mv -f mpipython mpipython-${EPYTHON} || die
- fi
-}
-
-python_test() {
- cd "${S}"/Tests || die
- nosetests -v -v || die
-}
-
-python_install() {
- distutils-r1_python_install
-
- if use mpi; then
- cd Src/MPI || die
- python_newexe mpipython-${EPYTHON} mpipython
- fi
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( Doc/Reference/. )
- use mpi && EXAMPLES=( Examples/mpi.py )
- distutils-r1_python_install_all
-}