summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-25 13:31:49 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-25 13:31:49 +0200
commita63602d7627411069bd4800a6bd15858cb801745 (patch)
tree69e9a78cd2a0c98d77c3d982b3727ce16f766cdb /dev-python/scikit-build
parentdev-python/scikit-build: Remove unnecessary PyQt5 dep (diff)
downloadgentoo-a63602d7627411069bd4800a6bd15858cb801745.tar.gz
gentoo-a63602d7627411069bd4800a6bd15858cb801745.tar.bz2
gentoo-a63602d7627411069bd4800a6bd15858cb801745.zip
dev-python/scikit-build: Use epytest --deselect instead of rm
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/scikit-build')
-rw-r--r--dev-python/scikit-build/scikit-build-0.11.1.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/dev-python/scikit-build/scikit-build-0.11.1.ebuild b/dev-python/scikit-build/scikit-build-0.11.1.ebuild
index 9cb69aa5691a..398a1f1c646a 100644
--- a/dev-python/scikit-build/scikit-build-0.11.1.ebuild
+++ b/dev-python/scikit-build/scikit-build-0.11.1.ebuild
@@ -41,14 +41,13 @@ distutils_enable_sphinx docs \
dev-python/sphinx-issues
distutils_enable_tests pytest
-python_prepare_all() {
- # Skip tests causing sandbox violations
- rm \
- tests/test_hello_cpp.py \
- tests/test_issue274_support_default_package_dir.py \
- tests/test_issue274_support_one_package_without_package_dir.py \
- tests/test_issue284_build_ext_inplace.py \
- tests/test_issue334_configure_cmakelists_non_cp1252_encoding.py \
- || die
- distutils-r1_python_prepare_all
+python_test() {
+ local deselect=(
+ # sandbox violations
+ tests/test_hello_cpp.py::test_hello_develop
+ tests/test_issue274_support_default_package_dir.py
+ tests/test_issue274_support_one_package_without_package_dir.py
+ tests/test_issue334_configure_cmakelists_non_cp1252_encoding.py
+ )
+ epytest ${deselect[@]/#/--deselect }
}