summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-20 09:01:04 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-20 11:10:13 +0100
commite6bd483153ff1fbb671eb9879386e0e00991fd78 (patch)
treeb563e10bf6c4203ddaa7d7660de79d3faba882c5 /dev-python/scipy
parentdev-python/mypy: Bump to 0.812 (diff)
downloadgentoo-e6bd483153ff1fbb671eb9879386e0e00991fd78.tar.gz
gentoo-e6bd483153ff1fbb671eb9879386e0e00991fd78.tar.bz2
gentoo-e6bd483153ff1fbb671eb9879386e0e00991fd78.zip
dev-python/scipy: Bump to 1.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/scipy')
-rw-r--r--dev-python/scipy/Manifest3
-rw-r--r--dev-python/scipy/scipy-1.6.1.ebuild155
2 files changed, 158 insertions, 0 deletions
diff --git a/dev-python/scipy/Manifest b/dev-python/scipy/Manifest
index 43540d9367ac..13ed408f42a5 100644
--- a/dev-python/scipy/Manifest
+++ b/dev-python/scipy/Manifest
@@ -16,3 +16,6 @@ DIST scipy-1.5.4.tar.gz 25237512 BLAKE2B 719cfecd6794b037dc636793ba38a3b39f5fd1a
DIST scipy-1.6.0-html.zip 23941941 BLAKE2B 3222e9b1e1aeebfd1ab0f8d179d25c25d6ab26a54c3d6c7f12d5cb24dd59af216685cb1db1d11980ca32c8e14595a1753b69438d8c7504f7c4fc1b386e1c944d SHA512 42cd5595e1f260bcd14d5ce159d9acd0eaefbcb1401270b90efe48b0e743681361dba5ee410e5932533bca03c19daaacb6042ef8edea9b2cccd5dae21a612072
DIST scipy-1.6.0-ref.pdf 34332184 BLAKE2B 948a03372797915e47d5e8ce44a32dcacb3448a20e06c5233d3362f0f04f228e8f7505aa918dbbd9a50ad64adb7a17181acab6a726ab251b8e8acf245a1550d6 SHA512 fe4c316f91cffb10d14207882ceb7a1d3711b03ad74857d771d0ec244caad60f878902f7279f6688c947fd415762abbb5a7082c810dd85c73385e8f58fbc056c
DIST scipy-1.6.0.tar.gz 27275413 BLAKE2B f65fca81a21a3077ead119123fc3bb2ed96aaacfee6f291473ef6780c291f3e9fee88d86501d4cb966f1d601fb7f0656956134f0437eb8fefb8030e762c363a5 SHA512 995ffaf56b713cdd4bdb98d8525b892e9ad84a511878b43213cb71a67f34d87c111da36cf1e0b044c75c0d5af64bfde4ad0f3e9c5e71cae2dbf053251f37064e
+DIST scipy-1.6.1-html.zip 23946591 BLAKE2B d3464c342b1d4f43e17e214c7557737913bf4131f88b9d569cff106c75dc7ebf0d065283792fddc189e2a3ddc322f1b2b4f38c6d313569f28395e79680060b58 SHA512 73561f9daa303c6e967f9b11952c6239dea7ff1a2fa02434354ac78fcffe7a552aa0f1043a17cb5c35a442def499eff199856cca8efa1415449cbf54f0d4913b
+DIST scipy-1.6.1-ref.pdf 34594740 BLAKE2B 905ddcd7a3d462b09ded688f0818204d7684fa18058d0dac480d0a000e9ea0b7ebcdd33c01adae17234dcdf630d4aef9078174127af46f1db55d5c14b3245346 SHA512 355f4681439c1720f45dca6badfe72d77edfca0962fd9b42df34f1cd8fff7121fa6e7f60570bb638abd3ba9693930fa46b25af862d8fc1568b508c6fdd785479
+DIST scipy-1.6.1.tar.gz 27346828 BLAKE2B 147d7b3f796023fe557f07b46eefa1b23631106556ff56bb0ab5640d7dccfa86fecc2031ba0571eee2560a9bf86705a5ef32527852650e6d0629a722574bf135 SHA512 778a7bca15bb880a3fd1c3d46ef753920335eca95fe5f2b8512883a2aec1bb8e9d8a8fdbf4fee90e823e31980408a51451cc53d4f10c632cd72faf2856c868c8
diff --git a/dev-python/scipy/scipy-1.6.1.ebuild b/dev-python/scipy/scipy-1.6.1.ebuild
new file mode 100644
index 000000000000..65a1f0129c60
--- /dev/null
+++ b/dev-python/scipy/scipy-1.6.1.ebuild
@@ -0,0 +1,155 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit fortran-2 distutils-r1 flag-o-matic multiprocessing toolchain-funcs
+
+DESCRIPTION="Scientific algorithms library for Python"
+HOMEPAGE="https://www.scipy.org/"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ doc? (
+ https://docs.scipy.org/doc/${P}/${PN}-html-${PV}.zip -> ${P}-html.zip
+ https://docs.scipy.org/doc/${P}/${PN}-ref-${PV}.pdf -> ${P}-ref.pdf
+ )"
+
+LICENSE="BSD LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc sparse test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-python/numpy-1.16.5[lapack,${PYTHON_USEDEP}]
+ sci-libs/arpack:0=
+ virtual/cblas
+ virtual/lapack
+ sparse? ( sci-libs/umfpack:0= )"
+RDEPEND="${DEPEND}
+ dev-python/pillow[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-lang/swig
+ >=dev-python/cython-0.29.13[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ doc? ( app-arch/unzip )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+src_unpack() {
+ default
+ if use doc; then
+ unzip -qo "${DISTDIR}"/${P}-html.zip -d html || die
+ fi
+}
+
+pc_incdir() {
+ $(tc-getPKG_CONFIG) --cflags-only-I $@ | \
+ sed -e 's/^-I//' -e 's/[ ]*-I/:/g' -e 's/[ ]*$//' -e 's|^:||'
+}
+
+pc_libdir() {
+ $(tc-getPKG_CONFIG) --libs-only-L $@ | \
+ sed -e 's/^-L//' -e 's/[ ]*-L/:/g' -e 's/[ ]*$//' -e 's|^:||'
+}
+
+pc_libs() {
+ $(tc-getPKG_CONFIG) --libs-only-l $@ | \
+ sed -e 's/[ ]-l*\(pthread\|m\)\([ ]\|$\)//g' \
+ -e 's/^-l//' -e 's/[ ]*-l/,/g' -e 's/[ ]*$//' \
+ | tr ',' '\n' | sort -u | tr '\n' ',' | sed -e 's|,$||'
+}
+
+python_prepare_all() {
+ # scipy automatically detects libraries by default
+ export {FFTW,FFTW3,UMFPACK}=None
+ use sparse && unset UMFPACK
+ # the missing symbols are in -lpythonX.Y, but since the version can
+ # differ, we just introduce the same scaryness as on Linux/ELF
+ [[ ${CHOST} == *-darwin* ]] \
+ && append-ldflags -bundle "-undefined dynamic_lookup" \
+ || append-ldflags -shared
+ [[ -z ${FC} ]] && export FC="$(tc-getFC)"
+ # hack to force F77 to be FC until bug #278772 is fixed
+ [[ -z ${F77} ]] && export F77="$(tc-getFC)"
+ export F90="${FC}"
+ export SCIPY_FCONFIG="config_fc --noopt --noarch"
+ append-fflags -fPIC
+
+ local libdir="${EPREFIX}"/usr/$(get_libdir)
+ cat >> site.cfg <<-EOF || die
+ [blas]
+ include_dirs = $(pc_incdir cblas)
+ library_dirs = $(pc_libdir cblas blas):${libdir}
+ blas_libs = $(pc_libs cblas blas)
+ [lapack]
+ library_dirs = $(pc_libdir lapack):${libdir}
+ lapack_libs = $(pc_libs lapack)
+ EOF
+ cat >> setup.cfg <<-EOF || die
+ [options]
+ zip_safe = False
+ EOF
+
+ # Drop hashes to force rebuild of cython based .c code
+ rm cythonize.dat || die
+
+ # TODO
+ sed -e 's:test_magic_square_sparse_no_presolve:_&:' \
+ -i scipy/optimize/tests/test_linprog.py || die
+ sed -e "s:== 'levy_stable':in ('levy_stable', 'crystalball', 'ncf'):" \
+ -i scipy/stats/tests/test_continuous_basic.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ # bug 721860
+ test-flag-FC -fallow-argument-mismatch &&
+ append-fflags -fallow-argument-mismatch
+}
+
+python_compile() {
+ # FIXME: parallel python building fails, bug #614464
+ export MAKEOPTS=-j1
+
+ ${EPYTHON} tools/cythonize.py || die
+ distutils-r1_python_compile \
+ ${SCIPY_FCONFIG}
+}
+
+python_test() {
+ # fails with bdist_egg. should it be fixed in distutils-r1 eclass?
+ distutils_install_for_testing ${SCIPY_FCONFIG}
+ cd "${TEST_DIR}/lib" || die "no ${TEST_DIR} available"
+ PYTHONPATH=. "${EPYTHON}" -c "
+import scipy, sys
+r = scipy.test('fast', verbose=2)
+sys.exit(0 if r else 1)" || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && \
+ local DOCS=( "${DISTDIR}"/${P}-ref.pdf ) \
+ local HTML_DOCS=( "${WORKDIR}"/html/. )
+ distutils-r1_python_install_all
+}
+
+python_install() {
+ distutils-r1_python_install ${SCIPY_FCONFIG}
+ python_optimize
+}
+
+pkg_postinst() {
+ elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
+ elog "to your prefered image viewer. Example:"
+ elog " echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
+}