summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/scoop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/scoop')
-rw-r--r--dev-python/scoop/Manifest1
-rw-r--r--dev-python/scoop/metadata.xml15
-rw-r--r--dev-python/scoop/scoop-0.7.0-r1.ebuild24
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/scoop/Manifest b/dev-python/scoop/Manifest
new file mode 100644
index 000000000000..b6a81e4464db
--- /dev/null
+++ b/dev-python/scoop/Manifest
@@ -0,0 +1 @@
+DIST scoop-0.7.0.release.tar.gz 598566 SHA256 5f4630884bc4e2821f79766e57c07b19c5cb1f6a2440bb8f427f0ef2532be908 SHA512 4e8378b6c73ef7d3d2d6ad8387220e0659b12eed008d834fb99a661ff1ff5f6b842e897156cec41119f5c392e341c3e8e5b912f01f0728b585daab46aa07d270 WHIRLPOOL 48427059868c3fe6cc662c40cfb0cd5c11e34c440084d2b3fb0aab951a41c4d43f67a4b78ef3ba2b2ef29a9584587b3767a6b1469d8313df572cf8188a74b300
diff --git a/dev-python/scoop/metadata.xml b/dev-python/scoop/metadata.xml
new file mode 100644
index 000000000000..c699c152e1bc
--- /dev/null
+++ b/dev-python/scoop/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>slis@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ SCOOP (Scalable COncurrent Operations in Python) is a distributed task module
+ allowing concurrent parallel programming on various environments, from
+ heterogeneous grids to supercomputers.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">scoop</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/scoop/scoop-0.7.0-r1.ebuild b/dev-python/scoop/scoop-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..978e3e8d352e
--- /dev/null
+++ b/dev-python/scoop/scoop-0.7.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit distutils-r1
+
+DESCRIPTION="Distributed Evolutionary Algorithms in Python"
+HOMEPAGE="https://code.google.com/p/scoop/ http://pypi.python.org/pypi/scoop"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.release.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/greenlet-0.3.4
+ >=dev-python/pyzmq-13.1.0"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+S="${WORKDIR}/${P}.release"