summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-24 13:35:57 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-24 16:09:12 +0100
commitf466dc2742027264a5c3c188b248ad3507785179 (patch)
treeec25da4617ccafbef056ee95f94c897741e07dfc /dev-python/scripttest/scripttest-1.3.0.ebuild
parentnet-misc/curl: Fix name of quiche pkg-config file (diff)
downloadgentoo-f466dc2742027264a5c3c188b248ad3507785179.tar.gz
gentoo-f466dc2742027264a5c3c188b248ad3507785179.tar.bz2
gentoo-f466dc2742027264a5c3c188b248ad3507785179.zip
dev-python/scripttest: EAPI 7, py3.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/scripttest/scripttest-1.3.0.ebuild')
-rw-r--r--dev-python/scripttest/scripttest-1.3.0.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/dev-python/scripttest/scripttest-1.3.0.ebuild b/dev-python/scripttest/scripttest-1.3.0.ebuild
index d505e0bd6127..476a53290c92 100644
--- a/dev-python/scripttest/scripttest-1.3.0.ebuild
+++ b/dev-python/scripttest/scripttest-1.3.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
inherit distutils-r1
@@ -15,12 +15,7 @@ SRC_URI="https://github.com/pypa/scripttest/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="test"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-RDEPEND=""
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-python_test() {
- esetup.py test
-}
+distutils_enable_tests pytest