summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-09 22:37:38 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-10 00:16:26 +0200
commit8b11b42cd6a3587d1f3ffc33f035ebc0dd13cda6 (patch)
treea252794ab7180cc64d2ae8264205c37376451b53 /dev-python/scrypt/scrypt-0.8.16.ebuild
parentdev-python/pyrsistent: Bump to 0.17.2 (diff)
downloadgentoo-8b11b42cd6a3587d1f3ffc33f035ebc0dd13cda6.tar.gz
gentoo-8b11b42cd6a3587d1f3ffc33f035ebc0dd13cda6.tar.bz2
gentoo-8b11b42cd6a3587d1f3ffc33f035ebc0dd13cda6.zip
dev-python/scrypt: Bump to 0.8.16
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/scrypt/scrypt-0.8.16.ebuild')
-rw-r--r--dev-python/scrypt/scrypt-0.8.16.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/scrypt/scrypt-0.8.16.ebuild b/dev-python/scrypt/scrypt-0.8.16.ebuild
new file mode 100644
index 000000000000..92065ee32932
--- /dev/null
+++ b/dev-python/scrypt/scrypt-0.8.16.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Bindings for the scrypt key derivation function library"
+HOMEPAGE="https://github.com/holgern/py-scrypt/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="libressl"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest