summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2019-01-02 11:39:05 +0000
committerJustin Lecher <jlec@gentoo.org>2019-01-02 11:39:25 +0000
commitdb4cb0819203e3246ead256bd1790b2445738d55 (patch)
treeb31ad40a9179dfc444f5b7cced8b4cd0c7a618c7 /dev-python/scrypt
parentnet-fs/netatalk: Drop old (diff)
downloadgentoo-db4cb0819203e3246ead256bd1790b2445738d55.tar.gz
gentoo-db4cb0819203e3246ead256bd1790b2445738d55.tar.bz2
gentoo-db4cb0819203e3246ead256bd1790b2445738d55.zip
dev-python/scrypt: Add missing dep on openssl
Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/scrypt')
-rw-r--r--dev-python/scrypt/scrypt-0.8.0.ebuild6
-rw-r--r--dev-python/scrypt/scrypt-0.8.6.ebuild9
2 files changed, 10 insertions, 5 deletions
diff --git a/dev-python/scrypt/scrypt-0.8.0.ebuild b/dev-python/scrypt/scrypt-0.8.0.ebuild
index e8a275ed3604..76f189daa364 100644
--- a/dev-python/scrypt/scrypt-0.8.0.ebuild
+++ b/dev-python/scrypt/scrypt-0.8.0.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
inherit distutils-r1
@@ -15,6 +16,7 @@ KEYWORDS="amd64 ~arm ~arm64 x86"
SLOT="0"
IUSE="test doc"
+RDEPEND="dev-libs/openssl:0="
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
@@ -22,5 +24,5 @@ DEPEND="${RDEPEND}
RESTRICT=test
python_test() {
- esetup.py test || die "tests failed"
+ esetup.py test
}
diff --git a/dev-python/scrypt/scrypt-0.8.6.ebuild b/dev-python/scrypt/scrypt-0.8.6.ebuild
index aa80ad170313..c886c88b999c 100644
--- a/dev-python/scrypt/scrypt-0.8.6.ebuild
+++ b/dev-python/scrypt/scrypt-0.8.6.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} pypy )
inherit distutils-r1
@@ -15,8 +16,10 @@ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
SLOT="0"
IUSE="test doc"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-libs/openssl:0="
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
python_test() {
- esetup.py test || die "tests failed"
+ esetup.py test
}