summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-25 23:45:37 +0000
committerSam James <sam@gentoo.org>2023-02-26 00:29:56 +0000
commit9ac0a321e63176ce49d5830281476e27bec05e6c (patch)
tree7fc30001aaca641574863bf861ee8c4e225e66c2 /dev-python/seaborn
parentapp-text/qpdf: add 11.3.0 (diff)
downloadgentoo-9ac0a321e63176ce49d5830281476e27bec05e6c.tar.gz
gentoo-9ac0a321e63176ce49d5830281476e27bec05e6c.tar.bz2
gentoo-9ac0a321e63176ce49d5830281476e27bec05e6c.zip
dev-python/seaborn: add 0.12.2
Closes: https://bugs.gentoo.org/880587 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/seaborn')
-rw-r--r--dev-python/seaborn/Manifest1
-rw-r--r--dev-python/seaborn/files/seaborn-0.12.2-matplotlib-3.7.patch19
-rw-r--r--dev-python/seaborn/seaborn-0.12.2.ebuild44
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/seaborn/Manifest b/dev-python/seaborn/Manifest
index 05272f65be96..0fa6e8e28578 100644
--- a/dev-python/seaborn/Manifest
+++ b/dev-python/seaborn/Manifest
@@ -1 +1,2 @@
DIST seaborn-0.12.0.tar.gz 1407601 BLAKE2B 3da8db0a0c08a40a3969a2ffce248f5521b4c7c93ecf0f014850093ef48331326454572ceea6ee1133805bf92540b0d2acecdfb7cb789d238f743b30e6a28947 SHA512 b2b06a22d48f19ace2448f465ca5e700f3486971d9fb86e85a1a8c9e2956b904e5f4c2c8075f848299b182cf8f69b2fac22366fedbd8012b9c44adc0bcb7e060
+DIST seaborn-0.12.2.tar.gz 1439798 BLAKE2B cf6903b1a2d27516bcafe46cabc81ea9fac80666394a6a82516630f9ac60afc7e9d31817e029cda9a08da04c0a37ce0244ad23acda16bca3283532ddb0fbdb71 SHA512 988a9922ee301b655911efa38905674b7dd15e7f7b157ad67f5befaeb02db492553f8bd6133b54d2dd7970b8dbbfd92d81d1faea3fa618247ebcaeb98620a060
diff --git a/dev-python/seaborn/files/seaborn-0.12.2-matplotlib-3.7.patch b/dev-python/seaborn/files/seaborn-0.12.2-matplotlib-3.7.patch
new file mode 100644
index 000000000000..dbc4908321d9
--- /dev/null
+++ b/dev-python/seaborn/files/seaborn-0.12.2-matplotlib-3.7.patch
@@ -0,0 +1,19 @@
+https://github.com/mwaskom/seaborn/commit/db7ae11750fc2dfb695457239708448d54e9b8cd
+
+From db7ae11750fc2dfb695457239708448d54e9b8cd Mon Sep 17 00:00:00 2001
+From: Michael Waskom <mwaskom@users.noreply.github.com>
+Date: Wed, 25 Jan 2023 16:58:26 -0500
+Subject: [PATCH] Update test to reflect change in matplotlib 3.7 (#3236)
+
+--- a/tests/test_axisgrid.py
++++ b/tests/test_axisgrid.py
+@@ -331,7 +331,7 @@ def test_subplot_kws(self):
+ g = ag.FacetGrid(self.df, despine=False,
+ subplot_kws=dict(projection="polar"))
+ for ax in g.axes.flat:
+- assert "PolarAxesSubplot" in str(type(ax))
++ assert "PolarAxes" in ax.__class__.__name__
+
+ def test_gridspec_kws(self):
+ ratios = [3, 1, 2]
+
diff --git a/dev-python/seaborn/seaborn-0.12.2.ebuild b/dev-python/seaborn/seaborn-0.12.2.ebuild
new file mode 100644
index 000000000000..276eda23158c
--- /dev/null
+++ b/dev-python/seaborn/seaborn-0.12.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="Statistical data visualization"
+HOMEPAGE="https://seaborn.pydata.org https://github.com/mwaskom/seaborn"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/statsmodels[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( dev-python/pytest-xdist[${PYTHON_USEDEP}] )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-matplotlib-3.7.patch
+)
+
+distutils_enable_tests pytest
+
+src_test() {
+ cat > matplotlibrc <<- EOF || die
+ backend : Agg
+ EOF
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ epytest -n "$(makeopts_jobs)"
+}