summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-20 10:02:52 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-20 10:02:52 +0200
commit765dccfb0b6f8ce54cbf2349fb0a6728e18d10b6 (patch)
tree772d4641983365075e4d077a0b305fe05a86fc52 /dev-python/selenium/selenium-3.141.0-r1.ebuild
parentdev-python/stack_data: Remove old (diff)
downloadgentoo-765dccfb0b6f8ce54cbf2349fb0a6728e18d10b6.tar.gz
gentoo-765dccfb0b6f8ce54cbf2349fb0a6728e18d10b6.tar.bz2
gentoo-765dccfb0b6f8ce54cbf2349fb0a6728e18d10b6.zip
dev-python/selenium: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/selenium/selenium-3.141.0-r1.ebuild')
-rw-r--r--dev-python/selenium/selenium-3.141.0-r1.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/selenium/selenium-3.141.0-r1.ebuild b/dev-python/selenium/selenium-3.141.0-r1.ebuild
deleted file mode 100644
index 87cb9bb3c3d2..000000000000
--- a/dev-python/selenium/selenium-3.141.0-r1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python language binding for Selenium Remote Control"
-HOMEPAGE="https://www.seleniumhq.org"
-# pypi tarball misses tests, github tarball misses generated files
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
- test? (
- https://github.com/SeleniumHQ/selenium/archive/${P}.tar.gz
- -> ${P}.gh.tar.gz
- )"
-
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-LICENSE="Apache-2.0"
-SLOT="0"
-
-DOCS=( CHANGES README.rst )
-
-QA_PREBUILT="/usr/lib*/python*/site-packages/${PN}/webdriver/firefox/*/x_ignore_nofocus.so"
-
-RDEPEND="
- dev-python/urllib3[${PYTHON_USEDEP}]"
-BDEPEND="
- test? ( dev-python/pytest-mock[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests pytest
-
-src_unpack() {
- unpack "${P}.tar.gz"
- if use test; then
- cd "${S}" || die
- ebegin "Unpacking tests from ${P}.gh.tar.gz"
- tar -x -z -f "${DISTDIR}/${P}.gh.tar.gz" --strip-components 2 \
- "${PN}-${P}"/py/test
- eend ${?} || die
- fi
-}
-
-python_test() {
- pytest -vv test/unit || die "Tests fail with ${EPYTHON}"
-}