summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-19 15:34:23 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-19 15:39:21 +0200
commit55ec7af31d734a017cb00901c676e703338df226 (patch)
treed2e39696c2f00fea28f6539edd47194c2d859426 /dev-python/sentry-sdk
parentdev-python/urllib3: Remove old (diff)
downloadgentoo-55ec7af31d734a017cb00901c676e703338df226.tar.gz
gentoo-55ec7af31d734a017cb00901c676e703338df226.tar.bz2
gentoo-55ec7af31d734a017cb00901c676e703338df226.zip
dev-python/sentry-sdk: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sentry-sdk')
-rw-r--r--dev-python/sentry-sdk/Manifest1
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.5.7.ebuild80
2 files changed, 0 insertions, 81 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index c41fd11fe043..635c94622100 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1,2 +1 @@
-DIST sentry-sdk-1.5.7.gh.tar.gz 244753 BLAKE2B 343c9439525f7609eb3c3962213c8c4b5493d2ace8143d3bb36cd4b13463f4548597f80ac49288d925e0f03a9675b1ed24744eb4cfa3dbe2700a19f2e03585d3 SHA512 8d5e41967387463ed50b4cd582ac0492905bb9cd8740054690f176b8ba07a095836141f4f23791a83909bdb18d4b006aeb0ff963c1663f97305bbdd819a2889a
DIST sentry-sdk-1.5.8.gh.tar.gz 245374 BLAKE2B 0a94db069786813ce38346d50c51173cef5a47099232d56ecc561ebaf7e9ff3ef1063f964370aaf0f184ec02af7652db59153fa1bf3425e6c75c0a4c73c4ede2 SHA512 992cebceb9b3b2a861b6f084a1ae88f93a8cf740b8f0407550c31af9a9332afdeeb6e64d0dd29b2f80ac1cdade942ada90756c6fbc3373f3ee1948b9d037b59b
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.5.7.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.5.7.ebuild
deleted file mode 100644
index 10c2be51e86a..000000000000
--- a/dev-python/sentry-sdk/sentry-sdk-1.5.7.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python client for Sentry"
-HOMEPAGE="https://sentry.io/ https://pypi.org/project/sentry-sdk/"
-SRC_URI="
- https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-S="${WORKDIR}/sentry-python-${PV}"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~riscv ~sparc x86"
-
-RDEPEND="
- dev-python/urllib3[${PYTHON_USEDEP}]
- dev-python/certifi[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/asttokens[${PYTHON_USEDEP}]
- dev-python/django[${PYTHON_USEDEP}]
- dev-python/executing[${PYTHON_USEDEP}]
- dev-python/fakeredis[${PYTHON_USEDEP}]
- dev-python/flask-login[${PYTHON_USEDEP}]
- dev-python/gevent[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/pyrsistent[${PYTHON_USEDEP}]
- dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
- dev-python/pytest-django[${PYTHON_USEDEP}]
- dev-python/pytest-forked[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
- dev-python/zope-event[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/eventlet[${PYTHON_USEDEP}]
- ' python3_{8..9})
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # tests require Internet access
- tests/integrations/httpx/test_httpx.py
- tests/integrations/requests/test_requests.py
- tests/integrations/stdlib/test_httplib.py
- # wtf is it supposed to do?!
- tests/integrations/gcp/test_gcp.py
- # broken by rq-1.10.1 (optional dep)
- tests/integrations/rq/test_rq.py
-)
-
-EPYTEST_DESELECT=(
- # hangs
- 'tests/test_transport.py::test_transport_works'
- # TODO
- 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
- tests/test_client.py::test_databag_depth_stripping
- tests/test_client.py::test_databag_string_stripping
- tests/test_client.py::test_databag_breadth_stripping
- tests/integrations/asgi/test_asgi.py::test_websocket
- # incompatible version?
- tests/integrations/falcon/test_falcon.py
- tests/integrations/sqlalchemy/test_sqlalchemy.py::test_too_large_event_truncated
- # test_circular_references: apparently fragile
- 'tests/integrations/threading/test_threading.py::test_circular_references'
- # test for new feature, fails with IndexError
- tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
- # TODO
- tests/integrations/wsgi/test_wsgi.py::test_auto_session_tracking_with_aggregates
-)