summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-19 10:01:48 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-19 10:05:08 +0100
commit16d9e0dea6e263305b68d0cd183e7d52fcb4b80d (patch)
tree23f7c083fe3bdb406749e79ac5fedcf4b3db43bd /dev-python/setuptools-git/setuptools-git-1.2.ebuild
parentdev-python/pytest-fixture-config: Fix remaining MissingTestRestrict (diff)
downloadgentoo-16d9e0dea6e263305b68d0cd183e7d52fcb4b80d.tar.gz
gentoo-16d9e0dea6e263305b68d0cd183e7d52fcb4b80d.tar.bz2
gentoo-16d9e0dea6e263305b68d0cd183e7d52fcb4b80d.zip
dev-python/setuptools-git: Enable py3.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/setuptools-git/setuptools-git-1.2.ebuild')
-rw-r--r--dev-python/setuptools-git/setuptools-git-1.2.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/dev-python/setuptools-git/setuptools-git-1.2.ebuild b/dev-python/setuptools-git/setuptools-git-1.2.ebuild
index 28a24814fe38..2bc70bc711f7 100644
--- a/dev-python/setuptools-git/setuptools-git-1.2.ebuild
+++ b/dev-python/setuptools-git/setuptools-git-1.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
inherit distutils-r1
@@ -15,12 +15,11 @@ SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- dev-vcs/git"
+ dev-vcs/git"
RDEPEND="${DEPEND}"
python_test() {
git config --global user.name "test user" || die
git config --global user.email "test@email.com" || die
esetup.py test
- retr=$?
}