summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-11-12 13:07:07 -0500
committerTim Harder <radhermit@gentoo.org>2017-11-13 15:08:34 -0500
commit7a0c4df308407e5dfffcb2be11c2bd73c290f978 (patch)
treeeb4b40c2e4da12099c63841e12e3b4c94cda1aa8 /dev-python/setuptools/setuptools-36.7.2.ebuild
parentmedia-sound/abcmidi: version bump to 2017.11.08 (diff)
downloadgentoo-7a0c4df308407e5dfffcb2be11c2bd73c290f978.tar.gz
gentoo-7a0c4df308407e5dfffcb2be11c2bd73c290f978.tar.bz2
gentoo-7a0c4df308407e5dfffcb2be11c2bd73c290f978.zip
dev-python/setuptools: version bump to 36.7.2
Diffstat (limited to 'dev-python/setuptools/setuptools-36.7.2.ebuild')
-rw-r--r--dev-python/setuptools/setuptools-36.7.2.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/setuptools/setuptools-36.7.2.ebuild b/dev-python/setuptools/setuptools-36.7.2.ebuild
new file mode 100644
index 000000000000..b9335a39d953
--- /dev/null
+++ b/dev-python/setuptools/setuptools-36.7.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/pypa/setuptools.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+ KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="https://github.com/pypa/setuptools https://pypi.python.org/pypi/setuptools"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ test? (
+ dev-python/pip[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+ dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+ >=dev-python/backports-unittest-mock-1.2[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ >=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]"
+
+# Force in-source build because build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( {CHANGES,README}.rst docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
+
+python_prepare_all() {
+ if [[ ${PV} == "9999" ]]; then
+ python_setup
+ ${EPYTHON} bootstrap.py || die
+ fi
+
+ # disable tests requiring a network connection
+ rm setuptools/tests/test_packageindex.py || die
+
+ # don't run integration tests
+ rm setuptools/tests/test_integration.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
+ # It tries to sandbox the test in a tempdir
+ HOME="${PWD}" py.test --verbose ${PN} || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+ distutils-r1_python_install
+}