summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-15 23:55:40 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-15 23:58:58 +0100
commit4c0c94953669c05eed684c9724f55a63a305e529 (patch)
tree5da9cb5299c584f48b3884be0883a8d805c37b41 /dev-python/setuptools
parentdev-python/oslo-config: Bump to 8.8.0 (diff)
downloadgentoo-4c0c94953669c05eed684c9724f55a63a305e529.tar.gz
gentoo-4c0c94953669c05eed684c9724f55a63a305e529.tar.bz2
gentoo-4c0c94953669c05eed684c9724f55a63a305e529.zip
dev-python/setuptools: Bump to 60.9.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/setuptools')
-rw-r--r--dev-python/setuptools/Manifest1
-rw-r--r--dev-python/setuptools/setuptools-60.9.1.ebuild113
2 files changed, 114 insertions, 0 deletions
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
index c23161fd6197..a41a6aa816d4 100644
--- a/dev-python/setuptools/Manifest
+++ b/dev-python/setuptools/Manifest
@@ -3,3 +3,4 @@ DIST setuptools-60.5.0.tar.gz 2292478 BLAKE2B e41b2717b34d454b3959ee5b6f4fdc70df
DIST setuptools-60.7.1.tar.gz 2358541 BLAKE2B b48443b95cbd3891ec93d743eb4177302df6742624ea97a97779dd3f101c089ed38ba41d2ff65d35d7e3646d50e62111ecbdd23da9a45cab956006c38d1a42d0 SHA512 cf04353ffc2b1ca30fb219f00265eb6f89330f5489e57997d6975725a19b1e037ab02b9b74a8fcdc84a6234349cfc64855ae57535e0faa46ce4b280a364bb862
DIST setuptools-60.8.0.tar.gz 2397546 BLAKE2B 6522057b03fcfc8a0be9806ac74964d6d792878c3daf4873b854f64c66685aa0ba4166cb9cf92edeac134bc27c900a457758e68bbb48e4d9d1c0f54c6b76a68d SHA512 5466c0ff15d74b06bb50d660a2890b1ecd28bdda32f70d8343c3adcb894a23c129f127cf0a49ab1db9ac1a648472b956b73caae80d08a2353979d47da3d155d6
DIST setuptools-60.9.0.tar.gz 2416431 BLAKE2B 70dde8a23054aad0a8d5ff4a0dd812619d6d4a8885021eaf20c8b0af95ae571926fb99cb93be1bad4a2a5b24ea507701a17f890e6bae132338b6e7b5cf3fe4c9 SHA512 ef21ffc1ed3d90d075345d98d8daa6ee296613294b2fd8581cc891aac190d6ef36af0a7cbb92e64fc40f6cde813c43303bdc110b13191514fb263f82f74c243d
+DIST setuptools-60.9.1.tar.gz 2417022 BLAKE2B 2f64be8e3d7cc912fa26097ceac4d40caf21aa54d8fb72c3bd16b8a6b6e47171bf822978b2245fcb0c00ddfcc4f283868cfc60e744a8e34a4a4c3045a6b3bba8 SHA512 cca4db6658f9b0f2e97f24420e51c7a829a92d4031ed065b1de472505cf29c94c135b096e2f616ff540ac4e8c31fff55f8f05b1938a5e6433af669c33f9e717d
diff --git a/dev-python/setuptools/setuptools-60.9.1.ebuild b/dev-python/setuptools/setuptools-60.9.1.ebuild
new file mode 100644
index 000000000000..7c438eb90965
--- /dev/null
+++ b/dev-python/setuptools/setuptools-60.9.1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 multiprocessing
+
+CPY_PATCHSET="python-gentoo-patches-3.10.0_p1"
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="https://github.com/pypa/setuptools https://pypi.org/project/setuptools/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://dev.gentoo.org/~floppym/python/${CPY_PATCHSET}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/appdirs-1.4.4-r2[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-text-3.7.0-r1[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-8.12.0-r1[${PYTHON_USEDEP}]
+ >=dev-python/ordered-set-4.0.2-r1[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3-r2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.10.1-r1[${PYTHON_USEDEP}]
+ ' python3_{8,9} pypy3)
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_resources-5.4.0-r3[${PYTHON_USEDEP}]
+ ' python3_8 pypy3)
+"
+BDEPEND="
+ ${RDEPEND}
+ >=dev-python/wheel-0.37.1-r1[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/build[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-envs-2.2[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-path-3.2.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/pip-run[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+ dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ ' python3_{8..10} pypy3)
+ )
+"
+PDEPEND="
+ >=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+DOCS=( {CHANGES,README}.rst )
+
+src_prepare() {
+ # remove bundled dependencies, setuptools will switch to system deps
+ # automatically
+ rm -r */_vendor || die
+
+ # remove the ugly */extern hack that breaks on unvendored deps
+ rm -r */extern || die
+ find -name '*.py' -exec sed \
+ -e 's:from \w*[.]\+extern ::' -e 's:\w*[.]\+extern[.]::' \
+ -i {} + || die
+
+ # apply distutils patches to the bundled distutils
+ pushd setuptools/_distutils >/dev/null || die
+ # TODO: distutils C++ patch?
+ eapply -p3 "${WORKDIR}/${CPY_PATCHSET}/0006-distutils-make-OO-enable-both-opt-1-and-opt-2-optimi.patch"
+ popd >/dev/null || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x SETUPTOOLS_USE_DISTUTILS=stdlib
+
+ # keep in sync with python_gen_cond_dep above!
+ has "${EPYTHON}" python3.{8..10} pypy3 || continue
+
+ local EPYTEST_DESELECT=(
+ # network
+ setuptools/tests/integration/test_pip_install_sdist.py::test_install_sdist
+ setuptools/tests/test_distutils_adoption.py
+ setuptools/tests/test_virtualenv.py::test_clean_env_install
+ setuptools/tests/test_virtualenv.py::test_no_missing_dependencies
+ 'setuptools/tests/test_virtualenv.py::test_pip_upgrade_from_source[None]'
+ setuptools/tests/test_virtualenv.py::test_test_command_install_requirements
+ setuptools/tests/test_setuptools.py::test_its_own_wheel_does_not_contain_tests
+ # unhappy with pytest-xdist?
+ setuptools/tests/test_easy_install.py::TestUserInstallTest::test_local_index
+ # TODO
+ setuptools/tests/test_easy_install.py::TestSetupRequires::test_setup_requires_with_allow_hosts
+ setuptools/tests/test_test.py::test_tests_are_run_once
+ )
+
+ # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
+ # It tries to sandbox the test in a tempdir
+ HOME="${PWD}" epytest \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" setuptools
+}