summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-08 09:36:49 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-08 16:38:49 +0100
commitfe33fcbdbcf88c2b7f5fd6584aa15fa36b9e653b (patch)
treed08b45ea06decd084daa7c2114f1573665d483af /dev-python/setuptools_scm/setuptools_scm-1.10.0.ebuild
parentMerge remote-tracking branch 'remotes/Elizafox/master' (diff)
downloadgentoo-fe33fcbdbcf88c2b7f5fd6584aa15fa36b9e653b.tar.gz
gentoo-fe33fcbdbcf88c2b7f5fd6584aa15fa36b9e653b.tar.bz2
gentoo-fe33fcbdbcf88c2b7f5fd6584aa15fa36b9e653b.zip
dev-python/setuptools_scm: Version Bump
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/setuptools_scm/setuptools_scm-1.10.0.ebuild')
-rw-r--r--dev-python/setuptools_scm/setuptools_scm-1.10.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/setuptools_scm/setuptools_scm-1.10.0.ebuild b/dev-python/setuptools_scm/setuptools_scm-1.10.0.ebuild
new file mode 100644
index 000000000000..784a6dfc876c
--- /dev/null
+++ b/dev-python/setuptools_scm/setuptools_scm-1.10.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="package to manage versions by scm tags via setuptools"
+HOMEPAGE="https://github.com/pypa/setuptools_scm https://pypi.python.org/pypi/setuptools_scm"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -v -v -x || die "tests failed under ${EPYTHON}"
+}