summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-03-19 01:29:30 -0400
committerTim Harder <radhermit@gentoo.org>2018-03-19 01:35:59 -0400
commit528dbc6694ed801b6f38bdd042198e3db6ecc5db (patch)
tree6be0717ca78312a392575b5288fe9392039e9cc4 /dev-python/setuptools_scm/setuptools_scm-1.15.7.ebuild
parentdev-python/setuptools-git: remove old (diff)
downloadgentoo-528dbc6694ed801b6f38bdd042198e3db6ecc5db.tar.gz
gentoo-528dbc6694ed801b6f38bdd042198e3db6ecc5db.tar.bz2
gentoo-528dbc6694ed801b6f38bdd042198e3db6ecc5db.zip
dev-python/setuptools_scm: version bump to 1.15.7
Diffstat (limited to 'dev-python/setuptools_scm/setuptools_scm-1.15.7.ebuild')
-rw-r--r--dev-python/setuptools_scm/setuptools_scm-1.15.7.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/setuptools_scm/setuptools_scm-1.15.7.ebuild b/dev-python/setuptools_scm/setuptools_scm-1.15.7.ebuild
new file mode 100644
index 000000000000..dc80764a3b50
--- /dev/null
+++ b/dev-python/setuptools_scm/setuptools_scm-1.15.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="package to manage versions by scm tags via setuptools"
+HOMEPAGE="https://github.com/pypa/setuptools_scm https://pypi.python.org/pypi/setuptools_scm"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~amd64-fbsd"
+IUSE="git mercurial test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ git? ( dev-vcs/git )
+ mercurial? ( dev-vcs/mercurial )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+# pypi tarballs don't include tests and github tarballs don't have proper internal versioning
+RESTRICT="test"
+
+python_test() {
+ distutils_install_for_testing
+ py.test -v -v -x -k testing/test_basic_api.py || die "tests failed under ${EPYTHON}"
+ py.test -v -v -x -k testing/test_functions.py || die "tests failed under ${EPYTHON}"
+ py.test -v -v -x -k testing/test_main.py || die "tests failed under ${EPYTHON}"
+ py.test -v -v -x -k testing/test_regressions.py || die "tests failed under ${EPYTHON}"
+ if use git; then
+ py.test -v -v -x -k testing/test_git.py || die "tests failed under ${EPYTHON}"
+ fi
+ if use mercurial; then
+ py.test -v -v -x -k testing/test_mercurial.py || die "tests failed under ${EPYTHON}"
+ fi
+}