summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-05-13 22:25:10 +0200
committerMichał Górny <mgorny@gentoo.org>2019-05-13 22:25:42 +0200
commitf38532799d08d32df2f0f92312a6862f3e49fcdd (patch)
tree14867a4fe7f76c237273a07c8422bf7ba773041f /dev-python/setuptools_scm
parentsys-process/cronie: arm64 stable (bug #685848) (diff)
downloadgentoo-f38532799d08d32df2f0f92312a6862f3e49fcdd.tar.gz
gentoo-f38532799d08d32df2f0f92312a6862f3e49fcdd.tar.bz2
gentoo-f38532799d08d32df2f0f92312a6862f3e49fcdd.zip
dev-python/setuptools_scm: Fix version conflict on upgrades
Fix loading the wrong version of setuptools_scm, effectively removing the need for self-blocker. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/setuptools_scm')
-rw-r--r--dev-python/setuptools_scm/setuptools_scm-3.3.1.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-python/setuptools_scm/setuptools_scm-3.3.1.ebuild b/dev-python/setuptools_scm/setuptools_scm-3.3.1.ebuild
index 4217156ad367..bd949c207fb6 100644
--- a/dev-python/setuptools_scm/setuptools_scm-3.3.1.ebuild
+++ b/dev-python/setuptools_scm/setuptools_scm-3.3.1.ebuild
@@ -18,7 +18,6 @@ IUSE="test"
RESTRICT="!test? ( test )"
DEPEND="
- !!<dev-python/setuptools_scm-3
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/pytest[${PYTHON_USEDEP}]
@@ -30,11 +29,18 @@ python_prepare_all() {
sed -i -e 's:test_pip_download:_&:' testing/test_regressions.py || die
# all fetch specific setuptools versions
rm testing/test_setuptools_support.py || die
+ # remove self-dependency
+ sed -i -e "/arguments\.update/s@scm_config()@{'version': '${PV}'}@" \
+ -e "/__main__/i del sys.path[0]" setup.py || die
distutils-r1_python_prepare_all
}
python_test() {
- distutils_install_for_testing
+ PYTHONPATH= distutils_install_for_testing
py.test -v -v -x || die "Tests fail with ${EPYTHON}"
}
+
+python_install() {
+ PYTHONPATH= distutils-r1_python_install
+}