summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-16 17:48:59 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-16 18:04:55 +0200
commitff407d5c605f2975be92c92b932c3a56199c6c47 (patch)
tree1e55272ffe3e79c81ba6803b730345c74f4c74e1 /dev-python/setuptools_scm_git_archive
parentdev-python/cython: Skip tests on pypy3 due segv (diff)
downloadgentoo-ff407d5c605f2975be92c92b932c3a56199c6c47.tar.gz
gentoo-ff407d5c605f2975be92c92b932c3a56199c6c47.tar.bz2
gentoo-ff407d5c605f2975be92c92b932c3a56199c6c47.zip
dev-python/setuptools_scm_git_archive: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/setuptools_scm_git_archive')
-rw-r--r--dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1-r5.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1-r5.ebuild b/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1-r5.ebuild
new file mode 100644
index 000000000000..cb642d3b9a19
--- /dev/null
+++ b/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1-r5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A setuptools_scm plugin for git archives"
+HOMEPAGE="
+ https://github.com/Changaco/setuptools_scm_git_archive/
+ https://pypi.org/project/setuptools_scm_git_archive/
+"
+SRC_URI="
+ https://github.com/Changaco/setuptools_scm_git_archive/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
+
+python_test() {
+ epytest tests.py
+}